Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know my question might be close to this question, but for me none of the solution fixed the issue completely, although one has improved the situation a bit.

Simply put, I have rendering problems on Chrome on pages what seem to use latest fancy flash and other eye-candy ( among them) stuff. I am experiencing vertical tearing.

Some examples:

text tearing image tearing

What I have:

OS: Ubuntu 12.04

Video Card: AMD HD4870 (still a beast of a card as it runs most new games on high end on high rezolution)

Video Driver: ATI Catalyst official 12.06 (as my video card is considered legacy nowadays, that's the driver to go. Installing the latest 12.10 driver renders me an error of card not supported).

Output of sudo lshw -c video

       description: VGA compatible controller
       product: RV770 [Radeon HD 4870]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:49 memory:d0000000-dfffffff memory:fe7e0000-fe7effff ioport:a000(size=256) memory:fe7c0000-fe7dffff

I have this issues only since I installed the official AMD drivers. Until then I was using the default mesa drivers, and everything was working as a peach. But then Steam came to Linux, and I just had to jump on it. Now my games run smoothly under Ubuntu with Steam, but I have this tearing issues in Chrome.

Ahh, by the way, on Firefox there are no issues.

From the above mentioned post, I have enabled the "tear free" option, and that seemed to reduce the problem a bit, but still didn't eliminate it.

Any suggestions would be welcomed.


Going to chrome://plugins/ at the flash-player section I have to following:

enter image description here

share|improve this question
Do you have anything in chrome://flags tweaked, especially relating to rendering/hardware acceleration? You might want to look there, it some of the flags could cause rendering problems. – Andrew Soutar Jan 8 '13 at 23:31
To my knowledge I haven't touched that part. – bioShark Jan 8 '13 at 23:36
up vote 1 down vote accepted

I have the same problems, seems that the new Pepper Flash version included by default with Chrome doesn't play well with AMD cards. I haven't found a good way to solve it yet, but a workaround is to just use the normal flash player included by Ubuntu instead.

To do that, go to chrome://plugins

  • On the right side of the screen, click on "Details" if neccasery.
  • Search for the Adobe Flash Player plugin and disable the PPAPI (pepper) plugin, leaving the other one enabled.
  • Restart the browser to apply the changes.

EDIT: Screenshot of what I meanScreenshot of Flash settings

share|improve this answer
Thanks for the answer. I have tried with both combinations: PepperFlash disabled and adobe-flashplugin disabled and with Pepper disabled and adobe-flashplugin enabled and the tearing is still there. :( Which one is the "other one" for you? – bioShark Jan 8 '13 at 22:02
The working combination for me is Pepper Flash disabled (Right now version 11.5) and the adobe flash plugin (version 11.2) enabled. Make sure to restart the browser too! – Gladen Jan 8 '13 at 22:06
I've added in my question the plugins I have for adobe flash player – bioShark Jan 8 '13 at 22:07
As my edit demonstrates I have the same combo. I am testing with this link:… Try to scroll through it. – bioShark Jan 8 '13 at 22:09
I added a screenshot of my setup. – Gladen Jan 8 '13 at 22:13

sorry to pop in on this so late. However I was also encountering the issue today and stumbled upon this. What fixed it for me was going to chrome://flags and enabling "Override software rendering list Mac, Windows, Linux, Chrome OS, Android Overrides the built-in software rendering list and enables GPU-acceleration on unsupported system configurations"

I guess for some reason for me 2D hw accel wasn't working.

Just adding this here in case anyone else ever has this issue.

Kind Regards, openSUSE user

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.