Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use an old laptop of which the keyboard does not work. I think a drink has been spilled over it a long time ago. This is not the problem, I'm just using an external keyboard via USB.

When I boot, the laptop goes into the grub menu, but it starts beeping quite loudly even after I selected ubuntu to boot. I found the following post How do I get GNU Grub to stop beeping and allow me to select an option from the boot menu? of which the first answer seems to agree with my problem. I think some key may have been short circuited. Also when the screen after the boot menu shows, it seems that indeed a key is pressed continuously (the screen writes 'aaaaaaaaaa..'). So probably the grub detects the notworking keyboard our can't handle the short circuited keys or something?

So my question is, how do I stop it from beeping? I can use this laptop, once it has booted it works well with an external keyboard, but the beeping is really annoying.

Any suggestions?

Btw, the ubuntu version is 10.4.

Thanks!

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

If you want to disable the keyboard, then you have a few options:

  • Unplug it from the motherboard
  • Look for a BIOS setting (I don't know if you can, but it would make sense if you were able to disable an internal keyboard from BIOS)
  • Take it out and replace it
share|improve this answer
    
Ok I was hoping to just find some grub setting or something. But I took the keyboard out of my laptop and it solved the problem, so thanks:) –  user1254962 Jan 10 '13 at 7:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.