Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To be sure connection is working i want to connect to same computer from same computer ive set up remote desktop.

Can't access from my Same comp to same comp to test if all is ok. Tried all mentioned posibilities.

  • Tryd my ip xxx.xxx.xxx.xxx / localhost
  • with / without :5900 added
  • with / without in "Remote desktop" checked "Configure network automatically to accept connection"
  • with / without in router WRT54G enabled port 5900 forwardet to my comp 192.168.1.3 UPNP is enabled.

I can connect to one other comp whitch isn't using router and checked "Configure network automatically to accept connection" and to one through TENDA W311R+ router where i've put port forwarding to 5900 and there works xxx.xxx.xxx.xxx:5900

What's wrong? What have i missed?

share|improve this question

closed as not a real question by izx, jokerdino, Anwar Shah, ajmitch, hbdgaf Aug 22 '12 at 1:49

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you ssh to your system, or otherwise test reachability? –  belacq Jan 28 '11 at 23:30
    
What program are you trying to use for the remote desktop? Also, try ssh like jgbelacqua says: ssh -p 5900 [email protected] –  djeikyb Jan 29 '11 at 0:55
    
Let me ask you one thing: are you trying to connect VNC using a computer and trying to connect to the same computer you are using? –  Bruno Pereira Jun 2 '12 at 16:53
    
Yes one same computer and cant –  Kangarooo Jun 2 '12 at 17:48
    
What error do you get when you try to connect? –  izx Jun 3 '12 at 10:34

4 Answers 4

Have you checked out how is your firewall handling the incoming requests?

What I think is that you are trying to use a system such as vnc or krdc in order to gain access to your desktop.

If you aren't using a firewall software, give a chance to "Firestarter" which is easily installed by dropping

sudo apt-get install firestarter

Or via Synaptic. After stopping the firewall check what happen when you try to get the connection. If this seems to solve your problem you should set an exception for this task.

share|improve this answer
    
Ubuntu's default firewall is ufw. Might try ufw disable. –  djeikyb Jan 29 '11 at 0:56
    
Thank you for your comment djeikyb :) –  Geppettvs D'Constanzo Jan 29 '11 at 19:34
    
Im just using Vino and Vinagre. –  Kangarooo May 26 '11 at 15:11
    
but if i havent installed firestarted then there is no firewall couse its clean installation. –  Kangarooo Nov 8 '11 at 17:03
    
Based on what they refer in this document: wiki.ubuntu.com/UncomplicatedFirewall "Ubuntu 8.04 LTS introduced ufw, and it is available by default in all Ubuntu installations after 8.04 LTS.", mentioned by @djeikyb on Jan-29. This isn't probably the case but all the possibilities should be considered in order to allow your connections to be established. If you experience errors with ufw enabled, try disabling it. Good luck! –  Geppettvs D'Constanzo Nov 8 '11 at 18:12

Use a vnc server that uses a separate X session, such as vnc4server.

share|improve this answer
    
i dont need another programm but find problem in this testing way of is all set up correct. –  Kangarooo Jun 3 '12 at 15:47

Yes one same computer and cant

You do understand that trying to connect to a running graphical (X) session from that same session via VNC is a problem? It's like being in a hall of mirrors. It does work though (see below).

Port forwarding, the router, firewalls, etc. have nothing to with connecting from computer A to computer A. The corollary (putting it another way) is that even if you succeed in connecting from Vinagre on A to Vino on A, it is no guarantee that you will be able to connect from computer B to computer A, because A-to-A does not involve your router, firewall, NAT, etc.

Please try from another computer on your network.

enter image description here

share|improve this answer
    
Thats no problem without router couse then it connect and mirroring no problem for testing –  Kangarooo Jun 3 '12 at 10:25
1  
Can we talk in chat? I'd really like to understand your problem and help you out. –  izx Jun 3 '12 at 10:32
    
If this will work then that means ive set all correctly. This i want for testing confirmation settings that all set ok. If this works then it will work with that ip. If A to A works then without testing and saving time ill know that B to A will work. I just dont have 2 ip adresses to test if ip A with router works. –  Kangarooo Jun 3 '12 at 10:46
    
That is a way to test if external ip connection is working.. –  Kangarooo Jun 3 '12 at 15:47

Fort fast and functionally connections with few configuration with intuitive GUI use Teamviewer7

You can choose .deb file for complete installation or

if you just run the executable file (last of the list) on both computer you don't even need an installation (but it requires wine to run).

Enter your ID and a password and you'll be securely remote connected with your pc.

enter image description here

It is even multiplatform. I was wasting a lot of time to configure my remote desktop but that was quick.

share|improve this answer
    
Thats great i know about it. Problem is with another programm to witch i need solution –  Kangarooo Jun 3 '12 at 15:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.