Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 32 bit as guest on Windows 7 64 bit. Everything is fine except one thing..when take my mouse pointer near the top edge(I set it at top) can't get the floating menu of virtual box in full screen mode...so I'm not able to minimize my Ubuntu virtual machine. Even worse the ctrl,alt+tab combination to switch out of windows is also not working.

I'm also running Linux Mint 13 Mate as guset where everything is fine so i guess this an Ubuntu problem may be related to compiz etc stuff.

Virtual Box version : 4.2.6

EDIT: guest additions are installed. Before installing additions Ubuntu was running in 1024x768 and now in full wide screen. As far as I remember the floating menu was available when guest additions were not installed.

thanks.

share|improve this question
    
Have you installed the VirtualBox Guest Additions in Ubuntu? –  Jose Elera Campana Jan 8 '13 at 19:31
    
yes...see the edit above –  rsjethani Jan 8 '13 at 20:42
    
Have you double-checked Settings under Machine > Settings > General > Advanced > Mini Toolbar? –  Томица Кораћ Jan 8 '13 at 20:51
    
yep...same as for the linux mint machine and I also have crunchbang linux and it also has the same settings. Both of which have visible floating menu –  rsjethani Jan 8 '13 at 20:53

3 Answers 3

solved

I have encountered the same problem after installing guest additions in my ubuntu. Do the following steps :

  • log into your OS which will be stretched or full screened most probably.
  • make sure your guest additions are activated.
  • press right Ctrl + F to bring up the windowed mode and you will see the toolbar there at the bottom or at top according to your settings made in the virtual box.
  • go to display settings from there and click on auto resize and the make it full screen.

Now you can see your toolbar along with full screen OS.

share|improve this answer

This is still a problem/bug and is references in the VirtualBox bug tracker here: https://www.virtualbox.org/ticket/9775

There is a work-around!

While in fullscreen mode in VirtualBox, log out of Ubuntu. When the login screen appears, you should be able to either see the mini-tool bar or you can press the HOST+Home keys to make it visible and it should show up.

I'm running Mint 17 x64 as my guest on my Win7 x64 host. I have the exact same issue with the fullscreen mini-tool bar, but logging out of Mint makes the toolbar appear. Strangely, when I move the fullscreen to my second monitor and log back in, the mini-tool now becomes visible whilst in the desktop environment.

Also: Ubuntu uses Unity and for me Mint uses Cinnamon, both of which are 3D accelerated Desktop Environments. Maybe MATE is not, which is why it works. If you turn of 3D Acceleration in the VBox settings for your guest, the mini-tool bar should work, but then you'll be in software rendering mode in Ubuntu Unity or Cinnamon.

share|improve this answer

Same here, but for me the <right Ctrl> + F hotkey still works. It will bring the screen back to Windowed view.

share|improve this answer
    
yes this works but it is not efficient. BTW your answer should be a comment –  rsjethani Jan 9 '13 at 5:37
    
Nope, it's not.. but it seems to be a VirtualBox bug so might be worth to report it to them too. Ow sorry, didn't know. Why should it be a comment actually? It is an answer to your question after all.. –  Gladen Jan 11 '13 at 8:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.