Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Help please with a little printer probem.

I am using a Sharp-MX-2310U printer on the network with Ubuntu 12.10. Followed all the normal setup and looking at cups localhost:631/printers/ I see the printer but no print jobs are printed and /var/spool/cups just keeps on filling with unfinished jobs.

The printer properties display the ink status etc so I do have connection to the printer but localhost:631/printers/ shows:

SHARP-MX-2310U SHARP MX-2310U Office Sharp MX-2300N Foomatic/pxlcolor (recommended) Idle - "Waiting for printer to finish."

Looking in localhost:631/admin/log/error_log I get a number of errors but nothing that is obvious.

    E [08/Jan/2013:10:31:26 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
    E [08/Jan/2013:10:31:26 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [08/Jan/2013:11:22:41 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
    E [08/Jan/2013:15:51:29 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
    E [08/Jan/2013:15:52:43 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    W [08/Jan/2013:15:53:22 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
    W [08/Jan/2013:15:53:22 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
    W [08/Jan/2013:15:54:04 +0000] [Job 1] The printer is unreachable at this time.
    W [08/Jan/2013:15:54:27 +0000] [Job 1] The printer is unreachable at this time.
    W [08/Jan/2013:15:54:40 +0000] [Job 1] The printer is unreachable at this time.
    E [08/Jan/2013:15:54:55 +0000] [Job 1] The printer is not responding.
    E [08/Jan/2013:16:08:22 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [08/Jan/2013:16:09:40 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [08/Jan/2013:16:11:33 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [08/Jan/2013:16:13:38 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
    E [08/Jan/2013:16:14:21 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    W [08/Jan/2013:16:14:45 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
    W [08/Jan/2013:16:14:45 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
    E [08/Jan/2013:16:28:03 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
    W [08/Jan/2013:16:28:04 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
    W [08/Jan/2013:16:28:04 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_SHARP_MX_2310U
share|improve this question
1  
Where did you get the driver? –  nick Jan 8 '13 at 17:25
    
When I install the printer the wizard asks me to select from a list. So I guess the driver is bundled with the Ubuntu release in some way. I also tried the driver found at sharp.co.uk/cps/rde/xchg/gb/hs.xsl/-/html/…. After the install I removed the old printer and re-installed with the same result –  Peter Mar 21 '13 at 10:55
add comment

1 Answer

I have the same issue except I have a Canon 1023N over ethernet. I have same errors. It looks like a known bug with cups. Lots of reports coming in now:

https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1053443

I wish I had known before I went and installed 12.10 as supposedly 12.04 does not have this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.