Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having some difficulty adding a new resolution using XRANDR and outputting it to my second monitor, which is a Panasonic Viera TX-P42G10E. This is what I run on my Ubuntu 12.04 LTS:

kapacs@LINUX:~$ cvt 1920 1200 60
# 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

I add it using --newmode and it successfully appears:

kapacs@LINUX:~$ xrandr
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 8192 x 8192
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   1360x768       60.0     59.8  
   1152x864       60.0  
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
LVDS-0 connected (normal left inverted right x axis y axis)
   1920x1200      60.0 +
DVI-D-0 disconnected (normal left inverted right x axis y axis)
  1920x1200_60.00 (0x2b5)  193.2MHz
        h: width  1920 start 2048 end 2256 total 2592 skew    0 clock   74.5KHz
        v: height 1200 start 1201 end 1204 total 1242           clock   60.0Hz

Then, when I try to assign it to the VGA-0 output terminal, it hits me with this.

kapacs@LINUX:~$ xrandr --addmode VGA-0 1920x1200_60.00 
 X Error of failed request:  BadMatch (invalid parameter attributes)
   Major opcode of failed request:  153 (RANDR)
   Minor opcode of failed request:  18 (RRAddOutputMode)
   Serial number of failed request:  27
   Current serial number in output stream:  28

Any advice is greatly welcome, I've tried the xorg.conf version as well and it did not work. Tutorial I tried. Thank you!

share|improve this question
add comment

2 Answers 2

I had similar problems with my Panasonic TX-42PX75U Plasma TV and generating correct modelines. My problem was resolved by generating an xorg.conf and adding the modelines manually from the following page: http://www.mythtv.org/wiki/Modeline_Database

You can see my related issue here: "DVI Monitor and HDMI TV on Intel HD4000"

share|improve this answer
add comment

A different name for the mode ending in letters solved the problem for me.

$ xrandr --verbose --newmode "1920x1200_60VGA" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync $ xrandr --verbose --addmode VGA-0 1920x1200_60VGA $ xrandr --verbose --output VGA-0 --mode 1920x1200_60VGA

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.