Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I open an application as root I get gnome2-like scrollbars which is fine.

But:

  1. the small arrows at top and bottom of the scrollbars are missing.
  2. the function of clicking between arrow and slider of the scrollbar to "scroll" down one page is also missing, it just jumps to the position of the cursor (making it really hard to scroll through huge list like in Synaptic).

scrollbars as root user

Is there any way to resolve these issues? Can't they look like in Firefox for example?

share|improve this question
    
You do know that running graphical apps as root user is mostly unnecessary and can be rather dangerous to your system? – guntbert Jan 8 '13 at 18:04
    
Sure I know. But for example Synaptic is started as root by default. – joschi Jan 8 '13 at 20:59
    
Inherently, Synaptic must be run as root, lest it be rendered useless. – Josh Jan 10 '13 at 5:02
    
For Synaptic I figured out that it was the latest BZR build I had installed, just reverted back to Quantal latest version. Question remains for other applications I run as root user. – joschi Jan 10 '13 at 18:33
    
Are you using sudo or gksu to run your applications? – InkBlend Feb 20 '13 at 5:26

I don't have a complete answer as I cannot find it in my backups. But I spent about 4 hours trying to remember how I did it last time. So in 2 areas changes are needed. Basically it breaks down to the theme you are using (i.e. mine is Ambiance) and making edits to File /usr/share/themes/Ambiance/gtk-3.0/gtk-widgets.css and /usr/share/themes/Ambiance/gtk-2.0/gtkrc for the root access and /home/USER/.config/gtk-3.0/gtk.css for the USER access.

In gtk-widgets.css I changed the scrollbar section to have the following and the same is in ~.config/gtk-3.0/gtk.css

/*************
* scrollbar *
*************/
.scrollbar,
.scrollbar.vertical {
    -GtkScrollbar-has-backward-stepper: 1;
    -GtkScrollbar-has-forward-stepper: 1;
    -GtkRange-slider-width: 16;
    -GtkRange-stepper-size: 16;
    -GtkRange-stepper-spacing: 0;
    -GtkRange-trough-border: 0;
    -GtkScrollbar-min-slider-length: 30;

The next edit maybe different if you are not using the same engine I have for the Gnome-flashback login that gives me Metacity? Find the section in /usr/share/themes/Ambiance/gtk-2.0/gtkrc that has sub section engine "murrine" {
bellow the style "default" { section and change:

engine "murrine" {
... other declarations
stepperstyle = 3
to

stepperstyle = 0

I believe The last line gives the even step scrolling down the page as opposed to jumping to the pointer or it just turns off the overlay-scrollbars? I have not figured out how to do this for something like synaptic.

share|improve this answer
    
So I remembered one other adjustment: in /usr/share/themes/Ambiance/gtk-3.0/settings.ini paste this; 'gtk-primary-button-warps-slider = false'. This will set one page at a time scroll as opposed to jumping to the pointer – user1870842 Mar 19 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.