Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed ubuntu 12.10 and in order to access the internet, I used my Smart Bro - Model MF180(Plug and Play USB Stick) but I can't connect to the internet. Are there some modifications or commands that I have to do to enable it?

share|improve this question
Have you checked this – VRU Jan 8 '13 at 15:41
not yet. going to check it. thanks :) – cabbit Jan 8 '13 at 15:44
oh, I have checked that one already but I don't know how does that "get the python script...and run.." so I can't really follow – cabbit Jan 8 '13 at 15:46
Your MF180 connects via USB? Run lsusb and give us the output so that we know the vendor ID and product ID of your Smart Bro, it works wonders when googleing for configuring USB peripherals in Linux. Also, did you install Ubuntu via Wubi? Do you have access to a computer where Ubuntu was installed directly to the hard disk without Wubi? – titaniumtux Jan 8 '13 at 15:48
Here are the results from lsusb: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub, Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub, Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub, Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub, Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub – cabbit Jan 8 '13 at 15:53

first thing you should do is to plug in your usb modem. next is click the icon on the upper right corner of your unity desktop. the one thats beside the rythmbox player. click edit connections. click the mobile broadband tab. click add then follow the instructions.after setting that up, close the network connections window. wait for a few seconds then click again the icon beside the rythmbox player. you should be able to click smart bro to connect to internet. a more detailed instructions can be found here

share|improve this answer
yeah. solved it for quite some time now. but either way, thanks :) – cabbit Jun 17 '13 at 11:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.