Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've read the thread here How can I disable arbitrary default multitouch gestures in Unity? where people seem to have solved their problems with touchegg in 12.10.

As for me, I'm able to install everything without errors but then when I bring up touchegg none of the gestures are recognized.

Two questions:

Do I need to get utouch installed? It is not a recognized package for 12.10.

When I run dpkg-buildpackage I have to use sudo. Could this affect the process? Should I get fakeroot?

p.s. I know my touchpad at least supports 3-finger gestures because I have used them with windows 8.

share|improve this question
Did you ever manage to resolve this? I have been looking for a fix myself to no avail so far. – JaredMcAteer Mar 21 '13 at 22:09
No, unfortunately not. It's kind of driving me crazy actually. If you do find a solution please let me know. – Fonnae Mar 22 '13 at 4:21
any ideas with this? – toto_tico May 10 '13 at 8:14

2 Answers 2

you need to disable the synclient links with synclient TapButton2=0 synclient TapButton3=0 synclient ClickFinger2=0 synclient ClickFinger3=0 synclient HorizTwoFingerScroll=0 synclient VertTwoFingerScroll=0

share|improve this answer
I tried doing that and it disabled my ability to scroll with two fingers etc. but when I launch touchegg is still doesn't recognize any of my gestures. It seems like something isn't working right. – Fonnae Jan 14 '13 at 19:56

I finally got this working to my liking. I have a desktop with Ubuntu 14.04.2 and Unity 7.2.5 with an Apple Magic Trackpad (and a bluetooth USB adapter). Hardware setup was basically seamless (easy, no drivers/etc, had a little trouble pairing at first, must hold the button down, no trouble since).

My problem was that touchegg and ginn could only be used for 4-finger gestures (Unity blocks or interferes with 2, 3, and 4-finger gestures). I've read using Gnome Desktop could solve the issue, but I'm used to (and already setup with) Unity. I wanted Unity's 2-finger gestures (horiz and vert scrolling), and fully configurable 3 and 4 finger gestures (for workspace switching, etc -- I'll update once I have my full set of gestures worked out.)

(Note I had previously followed xSwipe setup instructions here, didn't fully work, hopefully this didn't taint my setup.)

Here's what I did:

  1. Disable unity gestures as described in the referenced question (updated answer), recompile, restart. (This may not have been necessary, try first without.)
  2. May have to dis/enable bluetooth trackpad
  3. Run the referenced commands in the touchegg FAQ to disable synclient's use of 3 and 4 finger gestures (but leave horiz and vert scrolling):


  synclient TapButton2=0
  synclient TapButton3=0
  synclient ClickFinger2=0
  synclient ClickFinger3=0
  synclient HorizTwoFingerScroll=1
  synclient VertTwoFingerScroll=1

I will likely place these commands in my ~/.xinitrc as described in other questions.

I do notice that I still can't customize 2-finger gestures (even with horiz/vert disabled), but that's ok for me (for now), I like the default horiz/vert scrolling. Maybe sometime I'll want 2-finger pinch or something, but not yet.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.