Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, now I have a new problem... I installed Ubuntu on my new SSD today. But now Windows 8 doesn't show up in the boot loader anymore.

I ran Boot Repair and it told me

GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after reactivating the [Separate /boot/efi partition:] option.

Given that it seemed to be the easier option I tried activating the Separate /boot/efi option but Windows does not show up in my boot loader. Even worse, when I try to boot from the Windows SSD via my BIOS it gives me

Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key

So currently I can't get into my windows installation which is my primary and most important drive.

How can I fix this? Do I need to use Gparted? And if so, how exactly? I downloaded the tool but I have no idea what to do here - and I certainly don't want to destroy my Windows installation!

share|improve this question
Did this machine come with Windows 8 pre-loaded? –  Aditya Jan 8 '13 at 13:43
Are you able to see your data on the windows partition through the linux file manager? If so we are in luck. If not, there are a few things we can do. –  slayton1213 Jan 8 '13 at 13:46
No, it's a self-built desktop. –  cruxfilm Jan 8 '13 at 13:50
Yes, everything is there and looking good. –  cruxfilm Jan 8 '13 at 13:56
Please run Boot-Repair --> Create a BootInfo , and tell us the URL that will appear. –  LovinBuntu Jan 10 '13 at 7:28

1 Answer 1

you have to fix the mbr and reinstall the windows bootloader. Afterwards you need to update or reinstall grub to be able to boot to ubuntu.

Fix MBR and reinstall:

  1. Insert Microsoft Windows 8 installation disc in the drive.
  2. Make sure that first bootable device is set to CD/DVD from BIOS.
  3. Start your computer with DVD support.
  4. On the main page click on "Next" button leaving everything as default.
  5. On the next page click on "Repair your computer" link.
  6. On Choose an option window that appears click on Troubleshoot option.
  7. On Troubleshoot window click on Advanced options.
  8. On Advanced options window click on Command prompt.
  9. On the opened command window type BOOTREC /FIXMBR command and press enter key to fix MBR.
  10. Now restart your computer and you should see windows booting.

(Source: http://windows8themes.org/repair-fix-mbr-in-windows-8-using-the-command-prompt.html)

Your ubuntu system will not be gone. You can reinstall or update grub afterwards instead of reinstalling ubuntu completly.

To start ubuntu from Windows Bootmanager, there is a free Windows Tool called "EasyBCD" (Google) to configure the windows Bootloader (especially useful for adding a Linux OS to the windows bootloader)

Good Luck, have fun...

share|improve this answer
I tried this but the error is the same as before: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key. It told me The operation completed successfully. after the BOOTREC /FIXMBR command. But it seems the Command Line only ran on the USB drive itself (X:\Sources>). How can I tell it to do it for my actual system SSD C:\? (You can see the X:\ on the top here: i.imgur.com/v24Gd.jpg) It's a GPT drive, does that help? –  cruxfilm Jan 8 '13 at 14:59
try again and also run BOOTREC /FIXBOOT and BOOTREC /SCANOS in addition to BOOTREC /FIXMBR also be sure that your computer actually boots from the first partition ("C:/")... Windows is only able to install its bootloader to the primary disk, so there is no option to change the destination. –  mondjunge Jan 8 '13 at 15:12
Did all of that, all "operations completed successfully" but still no change. :/ –  cruxfilm Jan 8 '13 at 15:31
I am not sure what is going wrong. I presume Microsoft did not adapt their fix*-tools accordingly from BIOS/MBR to UEFI/GPT... I searched for this problem and found other peoples having the same problem, but no solution yet... sorry... :( One last recommendation: Save your data before playing any further, if not done already.. –  mondjunge Jan 8 '13 at 15:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.