Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having some difficulty installing Asterisk on a 64bit Server. I get the following error and cant seem to find help about this.

Failed to fetch http://za.archive.ubuntu.com/ubuntu/pool/main/o/openais/libsaevt3_1.1.4-4_amd64.deb  Hash Sum mismatch

My steps:

  • Remove /var/lib/apt/lists/*
  • Remove /var/cache/apt/lists/partial... failed file
  • apt-get clean
  • apt-get update

Outcome: Failed

Next step: Download the libsaevt.deb package and use dkpg -i to install package

Outcome: Failed

Please help!

share|improve this question

closed as too localized by qbi, Takkat, Uri Herrera, gertvdijk, Ringtail Jan 9 '13 at 0:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you sure about asterisk here? libsaevt belongs to openais which is a cluster frame work and shares no dependency with asterisk. –  qbi Jan 8 '13 at 11:05
    
Using sudo apt-get install asterisk, installs the packages but halfway through the installation I get the error? Should I rather manually compile asterisk? Or how can I perform the sudo apt-get install without apt trying to install libsaevt? –  Franna Jan 8 '13 at 11:25
    
Does apt-get update run without failure? If no, what is the exact error message? What is the error message if your run dpkg -i libsaevt…? –  qbi Jan 8 '13 at 11:35
    
Yes it does, I managed to get it fixed thanks. There was a missing dependency for libsaevt that I did not install. It works now without any problems. This question can be closed –  Franna Jan 8 '13 at 11:52
    
Good your problem is solved, but Hash Sum mismatch isn't a dependency issue. It clearly indicates that the package file libsaevt3_1.1.4-4_amd64.deb is corrupt or tampered with from your download source. Choose another mirror and redo the steps you already did. (this is for possible future visitors mostly) –  gertvdijk Jan 8 '13 at 23:14
add comment

Browse other questions tagged or ask your own question.