Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I installed ubuntu 12.04 and I chose to install 'alongside windows 7'.

After installation and restart, Windows 7 loaded but there is no sign that Ubuntu is actually installed.

Windows 7 is installed in hdd0, boots in legacy mode (only 1 HD in machine), UEFI secure boot is disabled.

I don't see anything on UEFI boot.

My partitions on my 1TB HDD:

  1. 100MB ntfs (win 7 installtion made it automatically)
  2. 200GB NTFS (Win 7 partition)
  3. 4 GB Partition ( idk what file sys)
  4. rest all unallocated
    yesterday I deleted the unused 4 gb partition
    current OS is running on live usb fat 32
    The result of fdisk -l is in the pic
    Result of sudo parted -l
share|improve this question

marked as duplicate by Eliah Kagan, Kevin Bowen, Jorge Castro, Raja, stephenmyall Jul 31 '13 at 10:37

This question was marked as an exact duplicate of an existing question.

Is it possible you started the live CD but did not install Ubuntu? Since... 'unallocated' means non-formatted and without formatting something to ext3 or ext4 you can not install Linux. – Rinzwind Jan 8 '13 at 9:16
I did installed it. It gave me 3 options<br/> (1)alongside win7<br/>(2)replace win7<br/>(3)something else( for repartitioning ,formatting, swap, ext drive etc.) i chosed alongside win 7. – Gaurav Sharma Jan 8 '13 at 9:19
Can you boot from the Live CD, and start Disk Utility to see if the rest of the data is really unallocated? – Gerhard Burger Jan 8 '13 at 9:32
What did you install first, Windows or Ubuntu? – Melon Jan 8 '13 at 9:33
windows 7 was installed 1st – Gaurav Sharma Jan 8 '13 at 9:54


Reinstall GRUB2 to the MBR, either:

* This should fix the problem even though in this case it was not caused by a recent installation of Windows, see below.


You're installing alongside Windows 7 (not Windows 8 or later) and there's no reason to believe this is a UEFI system (no "Secure Boot"). Therefore, we should expect that the cause of this problem is the usual cause of Ubuntu failing to boot after being installed as a fully-fledged (i.e., non-Wubi) system.

Sometimes Ubuntu's installer will not successfully install the GRUB2 boot loader to the Master Boot Record. As I answered in this related (but somewhat different) question:

While most installations go without anything going wrong, this is actually one of the more common installation problems. It can occur if you manually tell the installer not to install GRUB to the master boot record of the first hard drive, if it identifies the first hard drive incorrectly (its idea of first isn't necessarily what the BIOS tries to boot first), if it thinks a suitable boot loader is already in place (and is wrong), and possibly for other reasons.

Reinstalling the GRUB2 boot loader to the master boot record of the drive that the BIOS is trying to boot almost always solves this problem. When someone with a working Ubuntu system installs a Windows system alongside Ubuntu, the Windows installer will overwrite the master boot record with its own boot loader, which does not detect and provide an option to boot Ubuntu. That's what your situation has in common with that of users who've just installed Windows beside Ubuntu.

share|improve this answer
i got sudo blkid – Gaurav Sharma Jan 9 '13 at 8:14
I have posted the screenshot of fdisk -l using live ubuntu 12.04 – Gaurav Sharma Jan 9 '13 at 9:04
posted sreenshot of parted -l – Gaurav Sharma Jan 9 '13 at 9:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.