Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
techalay@ubuntu:~$ sudo bbb-conf --setip
[sudo] password for techalay: 
Assigning for testing for firewall in /var/www/bigbluebutton/client/conf/config.xml
Assigning for rtmp:// in /var/www/bigbluebutton/client/conf/config.xml
Assigning for servername in /etc/nginx/sites-available/bigbluebutton
Assigning for http:// in /var/www/bigbluebutton/client/conf/config.xml
Assigning for web application URL in /var/lib/tomcat6/webapps/bigbluebutton/WEB-INF/classes/
Assigning for api demos in /var/lib/tomcat6/webapps/demo/bbb_api_conf.jsp
Assigning for record and playback in /usr/local/bigbluebutton/core/scripts/slides.yml
Restarting the bigbluebutton server ...
 * Stopping Red5 Server red5                                                              [ OK ] 
 * Stopping Tomcat servlet engine tomcat6                                                 [ OK ] 
Stopping nginx: nginx.
Killing: 4600
Stopping OpenOffice headless server.
Record and Playback monitoring stopped

Starting FreeSWITCH
Error: stacksize -1 is too large: run ulimit -s 240 or run /opt/freeswitch/bin/freeswitch -waste.
auto-adjusting stack size for optimal performance...
5553 Backgrounding.
Waiting for FreeSWITCH to start: ...........................
Starting OpenOffice headless server
Starting nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
configuration file /etc/nginx/nginx.conf test is successful
 * Starting Red5 Server red5                                                                      
                                                                                          [ OK ]
 * Starting Tomcat servlet engine tomcat6                                                 [ OK ] 
Record and Playback monitoring started
Waiting for BigBlueButton to finish starting up (this may take a minute): .Startup unsuccessful: could not connect to bigbluebutton api
share|improve this question

I'm one of the developers of BigBlueButton.

What's happening is that the bash script bbb-conf is trying to run

wget -O - --quiet

You can check this on the command line and should get

$ wget -O -

The wget is making an API call to BigBlueButton server (listening on port 80) get the current version of the API. Can you check that the server's IP address is and that port 80 is opened.

share|improve this answer
Hello Fred I get the same error when I try to open demo from my dev server. i.e. NoConfigFound . I tried the above command I do get return code as success there $ wget -O - <response><returncode>SUCCESS</returncode><version>0.8</version></response> In my config.xml I have set up the same IP i.e. But I get NoConfigFound when I try to join the demo in the dev server – Snedden27 Feb 19 at 15:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.