Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 5742Z using Ubuntu operating system - how do I disable the touch-pad click

share|improve this question
    
You have tagged your question with "unity". If it is because you are using unity you might want to mention it in the question -- makes it easier for people to give you an answer. –  Mussnoon Jan 28 '11 at 19:30

4 Answers 4

1/Paste this code in a file named (randomly ) touchpad.sh file :

#!/bin/sh

#
#    My touchpad for some reason is being reported as a wheel mouse instead of a touchpad so
#    that is the string I search for to get the deviceid
#
DEVICE_ID=`xinput -list | grep -i "wheel mouse" | grep id= | sed 's/.*id=\([0-9]*\).*/\1/' `

if xinput -list-props $DEVICE_ID | grep "Device Enabled" | grep "1$" > /dev/null
then
    xinput set-int-prop $DEVICE_ID "Device Enabled" 8 0
else
    xinput set-int-prop $DEVICE_ID "Device Enabled" 8 1
fi

2/ enable executing

sudo chmod 755 touchpad.sh

3/System --> Preferences --> Keyboard Shortcuts Create a shortcut to execute this file with command similar bash /path/to/sh/file/touchpad.sh

share|improve this answer

As an update to this : I have tried to access system>mouse and select the touchpad tab. There isn't one!

I have searched the internet and tried changing xorg.conf. This does not work. I am using ubuntu 10.04 and have also tried with 10.10

share|improve this answer
2  
Hi, welcome to Ask Ubuntu, the way this site works is you continuously update your question with information then people will start submitting answers. After you've edited it, feel free to delete this answer, thanks! –  Jorge Castro Jan 28 '11 at 20:21
    
Please read also the FAQ. –  ulidtko Jan 28 '11 at 22:48

We have solved this problem by upgrading to ubuntu 10.10. Ian had not upgraded but posted that the system had been upgraded expecting the problem to still exist.

share|improve this answer

If anyone comes looking for a solution to a similar problem:

You could try installing this package called gpointing-device-settings from the repositories. Then open up System->Preferences->Pointing Devices and configure your touchpad/mouse however you wish to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.