Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How to install software or upgrade from old unsupported release?

These update errors are preventing upgrade Ubuntu 11.04. (I want to ultimately upgrade to 12.04):

http://extras.ubuntu.com/ubuntu/dists/natty/main/source/Sources  404 Not Found
http://extras/ubuntu.com/ubuntu/dists/natty/main/binary-amd64/Packages  404 Not Found
http://extras/ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404 Not Found

I check for updates pretty often but recently these have cropped up. I'm learning as I go but need some assistance to resolve this. Any guidance would be greatly appreciated.

share|improve this question

marked as duplicate by Eliah Kagan, Eric Carvalho, Jorge Castro, fabricator4, Anwar Shah Jan 9 '13 at 8:10

This question was marked as an exact duplicate of an existing question.

This is because Natty Narwhal has expired(End of Life) and its your chance to upgrade to higher version. reference

share|improve this answer

it seems that extras not available in extras.ubuntu.com you need to disable the request by editing source list use following command

sudo gedit /etc/apt/sources.list

add # in following urls Eg. "#http://extras.ubuntu.com/ubuntu/dists/natty/main/source/Sources" "#http://extras/ubuntu.com/ubuntu/dists/natty/main/binary-amd64/Packages" "#http://extras/ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages"

and try updating.

or upgrade distro

share|improve this answer
    
Got it! Did it! Even upgraded to 12.04! Now I'm back to resolving the complete lack of audio output like my last upgrade... Thanks all! – BBonham Jan 9 '13 at 6:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.