Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two NTFS partitions (DOWNLOADS for downloaded files and VM for my VirtualBox .vdi file) for which i must have full permissions for my allday use account. They should be also automounting when i login to this account.

But i've also set Guest account for guests. For Guest account, i want make VM partition fully disabled and invisible (and thus it mustn't automount) but DOWNLOADS partition should be shared with limited privileges with Guest account.

Editing fstab i'm able to share DOWNLOADS partition with Guest on limited privileges but VM can be only set to limited and have disabled automounting - so guest can't mount it but it still can be seen in Nautilus, plus I must always mount it manually when i login to allday account.

Is there some trick to make what i want?

Here's my fstab config:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda1 :
UUID=35e66658-5ee9-40cf-bf56-8204959e3df0 / xfs defaults 01
#Entry for /dev/sda2 :
UUID=26c714cf-4236-45e7-9c46-cfcf91a215ae /home xfs defaults 02
#Entry for /dev/sda5 :
UUID=1315BCB027C44639 /media/DOWNLOADS ntfs-3g auto,uid=1000,gid=1000,umask=0022,nodev,locale=pl_PL.utf8 0 0
#Entry for /dev/sda6 :
UUID=60FF39EB72B72264 /media/VM ntfs noauto,uid=1000,gid=1000,umask=0077,nodev,locale=pl_PL.utf8 0 0
#Entry for /dev/sda7 :
UUID=c52411f5-105c-45d1-971f-412f962c350e none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Thanks

share|improve this question

1 Answer 1

I think i have solution, here it is: http://ubuntuforums.org/showthread.php?t=1678406:

The second "0" in umask=0077 combined with uid=gid=1000 will do that. Automounting has nothing to do with something being disabled or invisible. The last 2 "7" in umask=0077 will do what you want. Everyone will see that there is a /media/VM mountpount but only you will be able to open the folder. Get rid of the "noauto" option.

If someone know other solutions, post also, so we could preserve the diversity of solutions. :)

share|improve this answer
2  
I know u had to answer your own question, but, for completeness sake, post the solution here, not just the URL. Summarize the exact steps, parameters and settings required in your fstab. –  MestreLion Jun 13 '11 at 10:04
    
@MestreLion Read carefully last post of that topic @ ubuntuforums.org, also with quoted post of Morbius1. And i recommend to read Introduction to fstab @ Ubuntu Community Docs. Cheers –  ryniek Aug 17 '11 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.