Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first time replacing an OS with Linux. I want to replace windows with Ubuntu 12.10 on my Asus X401a. The laptop does not have an optical drive so I need to use a USB stick.

I've read all the topics I can find on the topic of installing on this particular machine to no avail. It seems that no one has a problem getting the USB stick to boot.

I have written the iso to USB using Startup Disk Creator, I disabled safe-boot, and fast-boot on the laptop but when I enter the bios and tell it to boot from USB (UEFI: CBM) it still boots into Windows 8. I've tried disabling all boot options except USB and it just boots right back into the bios.

Any help would be greatly appreciated as I bought this laptop specifically to run Ubuntu.

share|improve this question
    
got mine yesterday asus x200ca with win 8 and touchscreen - followed this and thanks!!! - power then f2 no function key for the bios - boot tab -> fast boot disabled, launch csm enabled then security tab and secure boot disabled - save and exit then at reboot hit escape to get the boot chooser screen - did not work with the sdcard slot but the sdcard worked fine in a usb sd adapter - you can use ubuntu or even xubuntu but you have to use something with 13.10 not older - everything works out the box just fine –  user248954 Feb 16 at 21:01

2 Answers 2

Well, after much trial and error (and ignoring work and sleep) I figured out the proper settings in the bios. So here you go:

Under 'Security' disable 'Secure Boot Control'

Under 'Boot' disable 'Fast Boot', then enable 'Launch CSM', then enable 'Launch PXE OpROM'

Save changes and restart. On restart press the esc key and choose to boot from USB.

share|improve this answer
    
These settings allowed me to boot my new Asus machine with a Ubuntu install disk. –  ddoxey Dec 14 '13 at 16:20

Well in my case, I have to put, f2 for access bios, and change 2 things, firts Under 'Security' disable 'Secure Boot Control' second enable 'Launch CSM', then enable 'Launch PXE OpROM'

share|improve this answer

protected by Braiam Feb 16 at 22:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.