Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The S605 printer from lexmark is found and there is a provided option for the S600 Series when installing it. However, after the installation process it says it needs the program /usr/lib/cups/filter//usr/local/lexmark/v3/bin/printfilter.

Now i know, that the downloadable packages from lexmark contain this file in a debian package, so i could use it from there, but: What does the structure above mean? ...//usr/local/...

Are these two different locations? And has the file to be in both?

Thanks in advance, it's impressive how you guys actually know what you're doing (in contrary to mac or most windows users.)

Update: After installinge the packages from lexmark (which are for 12.04) it says at printer state: idle .../printfilter has insecure permissions (0100775/uid=0/gid=0).

Can i modify the printfilter? Do i need to set up an administrative group? I read a guide somewhere, but didn't follow it for some reason i forgot.

share|improve this question

5 Answers 5

/usr/lib/cups/filter//usr/local/lexmark/v3/bin/printfilter

This should be 1 directory. The double // is evaluated as 1 / so it does nothing. It is probably to prevent inside the software that this dir is evaluated: /usr/lib/cups/filterusr/local/lexmark/v3/bin/printfilter. That would result in an unwanted error.

Permissions error

sudo chmod 755 /usr/local/lexmark/v3/bin
sudo chgrp root /usr/local/lexmark/v3/bin/printfilter

should do it (though the 2nd line might not be needed!). Probable reason for the error:

CUPS 1.5.0 has a new security policy for filters and backends not allowing group write permissions. See http://www.cups.org/documentation.php/doc-1.5/whatsnew.html

Scheduler

4. Filter security; Filters and backends must now have group
 write permissions disabled.

The package you used to install is probably from before this CUPS update.

share|improve this answer

I don't believe /usr/lib/cups/filter//usr/local/lexmark/v3/bin/printfilter is intended as one directory - /usr/lib/cups/filter/ typically has no subdirs.

But apparently you managed to install the desired package and now you're getting the new insecure permissions error. I'm assuming this message gives the directory as /usr/local/lexmark/v3/bin/printfilter below.

What you need to do is change the ownership of /usr/local/lexmark/v3/bin/printfilter:

$ sudo chown -R root /usr/local/lexmark/v3/bin/printfilter

Changing the group shouldn't be neccessary but if you want to be on the safe side, also do

    $ sudo chgrp -R root /usr/local/lexmark/v3/bin/printfilter

However, you do need to have root as the owner of /usr/lib/cups/filter/, if it isn't, do the same for that directory:

$ sudo chown -R root /usr/lib/cups/filter/

...and when you're done with changeing the permissions, do a reboot or:

$ sudo /etc/init.d/cups restart
share|improve this answer

Following this link, but change the group by " bin " (not by " root ")

http://community.linuxmint.com/hardware/view/13737

Allows me to print on a lexmark s815 on linux mint 14 (based on ubuntu 12.10 so on debian 7)

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Jan 12 '13 at 23:53

Worked for me on Linux Mint 15, Lexmark Platinium Pro905

  • Download and install Lexmark drivers and utilities Launch the lexmark
  • printer utility and follow the instructions to install your printer
  • sudo chmod 755 /usr/local/lexmark/v3/bin/printfilter sudo chgrp bin
  • /usr/local/lexmark/v3/bin/printfilter In the printer properties -> system preferences, enable remote administration

enjoy

share|improve this answer
    
Sorry, but that doesn't mean that it will work in Ubuntu. –  Braiam Oct 19 '13 at 13:26

This might only work on newer versions of cups. To reset cups use "sudo service cups restart" without quotation marks.

share|improve this answer
1  
That only restart the service, not the underlying issue. –  Braiam Sep 5 '13 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.