Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I have an nvidia geforce 295 GTX, and it works great in Windows.

However, when booting into Ubuntu I had intermittent problems for a while where the system theme went haywire, it looked like "windows classic" with gray windows et cetera. Then they stopped being intermittent, and I always had these boring gray windows. I tried finding a workaround uninstalling the nvidia drivers and downloading newer ones from Nvidias site.

I uninstalled them but couldn't shut down the xserver to command line. If I did /etc/init.d/gdm stop the system just hanged. I tried booting into recovery mode, but after a whole bunch of startup output my screen goes to sleep (eg no output).

Lastly this has escalated so now I don't get any image when I boot into a normal Ubuntu session

share|improve this question

marked as duplicate by Jorge Castro, fossfreedom Dec 29 '12 at 7:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) – Seth Dec 29 '12 at 4:23

You don't say if you are using the latest nvidia Drivers, which would be useful in order to give you an answer. But assuming that you have the latest nVidia Drivers installed, try setting up your nVidia Settings by dropping the next in a terminal:

sudo nvidia-settings

After entering your password the nVidia X Server Settings window will appear, and after adjusting the parameters that make your screen look as you wish, click on the "X Server Display Configuration" in the left pane, then just save your changes by clicking the "Save to X Configuration File" button.

After that, a soft reboot of the X will be enough but if you reboot your machine will also do the trick. In order to soft-restart the X, press the [Ctrl][Alt][F1] in order to go to the console (text only) mode and drop the next command:


Please make sure you save all your open documents prior to do this because of the system is going to close down your session without allowing you to save anything.

Log in again and see the changes. If your configuration remains, it's time for a hardware reboot. Do it and check.

IMPORTANT NOTE: either that you can drop the single nvidia-settings command in the terminal, it won't allow you to save the changes. Do it as suggested and let's see what happen.

Just a question: which window's decoration manager are you using? your problem sounds more like a problem with Emerald or something. Sorry if my answer isn't what you expected.

share|improve this answer
Thanks for the effort! However, I can't even get into a session. Both the recovery mode and the normal mode results (after a few bootup messages) in a blank screen. My monitor goes to sleep, there is absolutely no output at all. – Max Jan 28 '11 at 18:23
You are more than welcome Max, but I don't know what happens with your system, have you tried pressing the [Ctrl][Alt][F1] in order to go to the console mode (only text)? may be your system is turned on but the X server is stuck into something. If you can gain access to the console mode then use "killall5" in order to kill the previous X server session and try to restart the X by dropping the "startx" or "sudo startx" commands in the terminal. Good luck! – Geppettvs D'Constanzo Jan 28 '11 at 18:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.