Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh installation of Ubuntu 12.10 on a Packard Bell notebook, with Gnome3 instead of Unity. Now when I try to connect to a WPA/WPA2 Enterprise secured WLAN (PEAP Authentication, MSCHAPv2 as Inner Authentication), after entering the login details I'm prompted to either select a root CA or ignore the message. But I can't hit the buttons or tick the box to not ask again this question. It's completely unselectable, so I end up not being able to connect to the wifi. I also tried to select the CA before trying to connect, but what happens then is that the prompt appears while the system starts connecting to the wifi. Unfortunately, it fails to do so.

If you know a way to connect to a wifi with such configuration, I'm also happy with that. The used CA would be the Entrust.net Secure Server Certificate Authority.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I just had the same issue. I was able to resolve it by logging out, switching to Unity, and connecting to the network there. I think it had something to do with Gnome 3 desktop not being as integrated. I think it only lets you manage one "pop up menu" at a time. In Unity, it doesn't open the Network Settings in the background, so you can click Ignore or you can choose a CA.

If you don't have Unity even installed, I suppose you could also try to do it from the command line using the following:

  1. Create a wpa_supplicant.conf file. This seems to be a relatively good guide for how to create your configuration file, and I am drawing from it for the rest of the instructions. Your configuration file should look something like this:

    network = {
    
    ssid="Your_ssid_here"
    key_mgmt=WPA-EAP
    pairwise=TKIP
    group=TKIP
    eap=PEAP
    identity="user@your_domain"
    password="your_password"
    ca_cert="/path/to/cert"
    phase1="peapver=0"
    phase2="MSCHAPV2"
    }
    
  2. Then, you must start issue the following command:

    wpa_supplicant -B -c/path/to/wpa_supplicant.conf -iwlan0
    

    The "-B" flag makes the daemon run in the background. The "-c" followed by the path loads the config file you created earlier, and the "-iwlan0" should be replaced with your wireless interface.

  3. If you want to keep this after a reboot, add the following to your /etc/network/interfaces file.

    auto wlan0
    iface wlan0 inet dhcp
    pre-up wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
    post-down killall -q wpa_supplicant
    

Hope this helps! If you have questions, you can always check the man page for wpa_supplicant.

share|improve this answer
    
Thanks for your answer. Setting the wifi up through Unity worked perfectly fine, I stored the connection and hope that it will work after reboot. However, setting up the wpa_supplicant using the conf-file did not work. First thing is, it has to be network={ (without the spaces), apparently. Second thing is, even when doing so I get the error "ioctl[SIOCSIWENCODEEXT]: Invalid argument" when I enter the command you wrote down... –  Aurelin Feb 12 '13 at 23:33
    
So just configuring the connection through Unity desktop solves the problem? Still, this seems like a major regression from Gnome Shell 3.4... Isn't there a way to set the number of maximum pop-up windows through a G-conf key? –  João André Feb 15 '13 at 14:47
    
Yes, it indeed solves the problem, and after you have the connection stored, it will stay, so after a reboot you can just log in to Gnome Shell right away, as it apparently uses the same connection configuration. I think it's a bug in Gnome Shell... But maybe that's something one could try. –  Aurelin Feb 22 '13 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.