Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the German Apple keyboard for both MacOS X and Ubuntu 12.10.

$ lsbusb
...    
Bus 002 Device 004: ID 05ac:0250 Apple, Inc. MP110Z/B

I've successfully remapped the exchanged < and ^ keys with these lines in .Xmodmap:

keycode 49 = less greater less greater bar brokenbar bar 
keycode 94 = dead_circumflex degree dead_circumflex degree U2032 U2033 U2032

Nevertheless only the Right ALT key is working. I want to exchange them or make them both work. Any ideas?

share|improve this question
    
could you provide a little more explanation, is the right alt problem a separate issue or related to what you have done in xmodmap? –  compound eye Jul 22 '13 at 11:24
add comment

1 Answer

If you mean you have made a change in xmodmap and subsequently the change is only working for the right alt, this could be because you need to clear the current settings for the left alt modifier key before you make the change.

Something like this:

clear Mod1
add Mod1    = Alt_L Alt_R

documentation here: https://wiki.archlinux.org/index.php/Xmodmap

If you mean only one alt key is working initially, before anything is changed with xmodmap, maybe the only one alt key is set up as 'alt'. On english apple keyboards one alt is set up as a third and fourth level key, which allows you to choose alternate letter forms on the keyboard, eg 'ß' with the 's' key.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.