Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I searched in other topics without luck.

I've got an Eeepc 1000h and lubuntu 12.10.

When I turn down my laptop wireless capability (FN+F2) it turns down the usb external antenna as well.

I don't want to exclude for ever my internal wireless (as suggested in other answers) I would like to turn down wireless with its button leaving USB-external-wifi ON. As it is intended to be.

Any chance to get this working?

Thanks in advance.

rfkill list all

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: phy2: Wireless LAN
    Soft blocked: no
    Hard blocked: no
share|improve this question
    
post output of rfkill list all –  Web-E Jan 7 '13 at 12:05
    
Thanks for answering. Added rfkill in the first message. Cheers :) –  Baffone001 Jan 7 '13 at 12:32
    
Possible duplicate of askubuntu.com/questions/168032/… –  Gerhard Burger Jan 7 '13 at 13:03
    
Not a duplicate. I red it before posting. The solution given to the user was disable via terminal the internal wlan card which I'm trying to avoid. I would like to enable/disable wireless via keyboard buttons (FN+F2) -as it's supposed to be working- KEEPING external-usb-wifi active. Thanks for answering. –  Baffone001 Jan 7 '13 at 13:32

2 Answers 2

Adding some infos.

With

sudo iwconfig wlan0 txpower off

it turns off both. Anyway in 20 seconds it turns on automatically. (and the led stays on, btw)

The only solution I can get by myself is to turn it down via BIOS. What an ugly workaroud :-(

Expert needed here!

share|improve this answer

Like exposed in another answer I actually use this workaround.

Add the following line to /etc/network/interfaces:

iface wlan0 inet manual

Then Restart. This disables internal Wifi. (or whatever you call wlan0).

If I need my internal wifi working again then I command out it with # and restart.

This is a very bad thing, but it works. Now, I can't believe in this community there isn't anyone that can't fix this to make it goes as it is supposed to do.

In Windows it's easy and immediate. Why couldn't be like that in Ubuntu?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.