Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Ubuntu 12.04 installation the media keyboard shortcuts do not work after reboot. The shortcuts are still saved and visible in the control pane, but no action is performed when using those shortcuts.

Example:

I use Alt + + (Num Block) (louder) and Alt + - (Num Block) (quieter) on the numeric block. I also use Alt + PgUp (previous title) and Alt + PgDn (next title). All those shortcuts do not work after a reboot, independently of whether Clementine was launched or not.

Could anyone explain that behavior and know a workaround?

UPDATE:

I've set those keyboard shortcuts in the global Gnome keyboard configuration (sub-item "sound and media"). Clementine is configured to use the Gnome shortcuts.

share|improve this question
    
Could you clarify if you've set these shortcuts in Clementine or in Ubuntu itself? I'm inclined to saying Clementine but not sure because you don't mention that programme until the last part of your question. –  Tomas Jan 15 '13 at 12:05
    
@Tomas see updated question… –  feeela Jan 15 '13 at 13:17
    
Thanks for clarifying. I've tried to reproduce your problem in 12.10, but with no success. It still works after rebooting –  Tomas Jan 15 '13 at 19:29

1 Answer 1

Explain the issue

I haven't got a clue how this happened. I have a problem where the Commands information in CCSM is forgotten after rebooting, but that seems unrelated to what you have (I can fix this by setting the shortcuts through the Keyboard menu, what you refer to as "global Gnome keyboard configuration"). As stated in my comment, what you're trying to do works perfectly well on my system.

Workaround

The problem can be in the Keyboard shortcuts settings (the one that sets the command) or in the specific multimedia commands (the command that is executed). In this workaround I'll explain how to do both at the same time. The programme that sets the shortcuts doesn't know the actual shortcut to change the multimedia stuff and neither do I, so this will be the easier solution.

You could set the shortcuts in another way.

For this I know one way, you can try the Commands plugin in CompizConfig Settings Manager, CCSM. If memory serves me right, this plugin works well for 12.04. CCSM is in the repositories, so simply install it from the Software Centre. If you don't know it, be careful with this tool. It is an awesome little programme but it is very easy to mess up your system. There are other ways, possibly through gconf-editor, Google around a bit for that if you're interested.

In the alternative keyboard shortcuts manager you can enter a command to change the volume. I do not know which nifty command is used in Unity to show the notification with the current volume, so we'll have to stick with something old-fashioned: amixer.

I found a command to increase the volume with amixer at http://unix.stackexchange.com/questions/21089/how-to-use-command-line-to-change-volume:

amixer set Master 10%+

and

amixer set Master 10%-

If you bind these in the Commands plugin and assign a shortcut key you should be good to go.

Commands plugin in CCSM

Don't forget to enable the plugin on the left hand side if you haven't already. Let me know if this solves your issue or if something is unclear.

Edit: if you struggle with this problem as well, be sure to look at the OP's comment below, it might point you in the right direction

share|improve this answer
1  
This workaround does work and your thoughts brought to me some new ideas. However I wouldn't call it a solution. I'll pass the bounty to you for your effort, but will not accept this one as the correct answer. I also found another question based on your answer, where I learned that Ubuntu uses pulseaudio to manage sound input and output. So pactl set-sink-volume 1 -- +10% works for me. There are still open issues, as I need to create each shortcut with a shell command, e.g. clementine -t. –  feeela Jan 22 '13 at 14:27
    
Happy that I could've been of help. Thanks a lot for giving feedback, that'll make this workaround a bit better. Good luck in trying to fix this problem, looks like you'll manage eventually. –  Tomas Jan 22 '13 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.