Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just spent hours to configure the sound to work with HDMI. My last problem is, when I start playing sound the TV screen goes on and off, like when you change the resolution. When I stop playing sound, 3-5 seconds after, the same thing happen. I feel like everytime I play/stop the sound, the HDMI connection needs to be resetted. Really annoying!

To enable the sound over HDMI, I have done :

pactl set-card-profile 0 output:hdmi-stereo

Which basically set the pulse audio profile to HDMI.

share|improve this question

Depending on your sound hardware you may also find the appropriate port to where your digital HDMI sound goes. To list ports of cards available issue:

pacmd list-cards

Usually there are several profiles available to adress different ports. These will also be lsited with the command above. Try if selecting another profile gives you the expected results (replace <card-index> and <profile-name> with values read above):

pacmd set-card-profile <card-index> <profile-name>

If no profiles adressing different ports are available you can also change the port of a given sink with:

pacmd list-sinks  # to read the sink index for the next command
pcmad set-sink-port <sink-index> <port-name>

In case you have a graphical desktop you may also change the card profile with pavucontrol Install pavucontrol in the "Configuration" tab:

enter image description here

Note that different HDMI-profiles may be listed which all show up having the same name.

If all that fails you may try to disable HDMI-CEC on your TV set or try with a different HDMI cable as flickering of the screen on your TV set may indicate an erroneous electrical input on the HDMI-ports.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.