Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Edit: This is the solution should anyone have the same problem

After installing and configuring AWStats from the repository, and following instructions from here

https://help.ubuntu.com/community/AWStats

it will work fine, except the pictures/icons will not be shown (you will get an Error 404).

The proposed configuration of /etc/apache2/sites-available/default is

Alias /awstatsclasses "/usr/share/awstats/lib/"
Alias /awstatsicons/ "/usr/share/awstats/icon/"
Alias /awstatscss "/usr/share/doc/awstats/examples/css"
ScriptAlias /awstats/ /usr/lib/cgi-bin/
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch

but the actual URL when I open an image is

http://example.com/awstats-icon/other/awstats_logo6.png

edit the default file to make this line has a - and no "s" after "icon":

Alias /awstatsicons/ to /awstats-icon/

Then save the file and reload Apache2

sudo /etc/init.d/apache2 reload.

Icons should not be visible.

share|improve this question
    
If you are going to answer your own question, could you please limit your question to just the details of the problem you encountered? Then, answer your own question separately, below, and accept it. That way people can immediately see that there is an accepted solution. –  Kevin Bowen Jan 8 '13 at 2:25
    
My Apache complained about "Options ExecCGI ..." missing a +. The solution is adding this plus: "Options +ExecCGI ..." –  Arthur Borsboom Feb 28 at 19:38

1 Answer 1

I found the answer for AWStats under Ubuntu 12.10. Please see my edited question for details.

share|improve this answer
    
Welcome to Ask Ubuntu! Please keep the question in the question, and the answer in the answer. That is, you should edit your question again to remove anything that answers the question, and you should edit this answer to include in it any information that is part of the answer. –  Eliah Kagan Jan 8 '13 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.