Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Possible Duplicate:
How to install software or upgrade from old unsupported release?
How can I fix a 404 Error using the Ubuntu archives?

I am having trouble downloading the Ubuntu repositories:

$ sudo apt-get update
Failed to fetch
404  Not Found 

Failed to fetch
404  Not Found

I can connect to the server fine:

# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=52 time=149 ms
64 bytes from ( icmp_req=2 ttl=52 time=149 ms
64 bytes from ( icmp_req=3 ttl=52 time=149 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 149.221/149.305/149.355/0.321 ms

Here is my sources.list:

deb maverick main restricted universe
deb maverick-updates main restricted universe 
deb maverick-security main restricted universe

and system details:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.10
Release:    10.10
Codename:   maverick

Any ideas?

share|improve this question

marked as duplicate by Jorge Castro, Eliah Kagan, hhlp, Amith KK, Luis Alvarado Jan 7 '13 at 16:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 12 down vote accepted

As a release gets old (especially if it is not a LTS release), it becomes no longer hosted at However, the repository is still hosted at

So try changing your repository source to

share|improve this answer
Thanks - that did it. I am surprised there is no redirect. – hoju Jan 7 '13 at 2:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.