Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install Ubuntu 12.10 64 bit but I can't since Logitech MX 5500 Combo (Keyboard/Mouse) is not detected. I'm new to Ubuntu.

share|improve this question
    
Hi greapko, can you add what hardware you have and if you have already connected the bluetooth device to the PC. – Luis Alvarado Jan 6 '13 at 19:16
    
Can you try to unplug and plug again the small usb stick provided with the keyboard/mouse? Then type dmesg in a terminal and give the 20 latest line. – olivierb2 Jan 6 '13 at 19:45

That is part of a bug had been around for a while. Launchpad Bug 870227.

The only fix for now for 12.10 is to have a separate keyboard (or boot in to an OS that can modify your installation) and go in to /lib/udev/rules.d/97-bluetooth-hid2hci.rules and comment out these lines:

# Logitech devices
#KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
#RUN+="hid2hci --method=logitech-hid --devpath=%p"

Just put a # at the beginning like in the code above.

share|improve this answer
    
This worked great! Thanks for the answer. – ATLChris Feb 18 '13 at 14:53

This problem also occurs in 16.04 LTS.

The problem is that you can't enter the pin when trying to pair the keyboard/mouse in bluetooth settings.

Found this solution which works for my own MX 5500 Keyboard and mouse

https://bugs.launchpad.net/ubuntu/+source/udev/+bug/872940

On 15.10 Wily Werewolf though, the path to the modified file is:

/lib/udev/rules.d/97-hid2hci.rules

I modified line 14:

From:

KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]",

To:

KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]",

Thank you for sharing the solution :)

share|improve this answer
    
@ByteCommander: Sorry, that was accidental. I meant to make this comment on a different answer. – David Foerster Jun 13 at 9:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.