Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I' ve just installed Ubuntu 12.10 64 bits on my new laptop and my Logitech M510 mouse does not work. It worked perfectly on 11.04 but it stop woth the new version, I've read here that I need to install HID Point, but I'm having trouble with that too.

Here's my output of: lsusb

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1bcf:2885 Sunplus Innovation Technology Inc.

As you can see it recognizes de unifying receiver, but the mouse does not respond.

When I try to install HID Point I get this:

libpng does not exist
libtiff does not exist
Gathering System information and generating a log
Launching HIDPoint Installer
./hidpointsetup: error while loading shared libraries: libpng.so.3: cannot open shared object file: No such file or directory

I've installed the 32-bit libraries just as it says in the installation instructions but nothing works.

Thank you in advanced!

EDIT

On this thread: Logitech M515 does not work after upgrade to 12.04 They suggest this line "modprobe -r hid_logitech_dj && modprobe hid_logitech_dj" should fix the problem but I get this error when I execute it:

WARNING: Error inserting usbhid (/lib/modules/3.5.0-17-generic/kernel/drivers/hid/usbhid/usbhid.ko): Operation not permitted
FATAL: Error inserting hid_logitech_dj (/lib/modules/3.5.0-17-generic/kernel/drivers/hid/hid-logitech-dj.ko): Operation not permitted
share|improve this question
    
check out this link : askubuntu.com/questions/128345/… –  Mukund Jan 6 '13 at 21:21
    
this: modprobe -r hid_logitech_dj && modprobe hid_logitech_dj doesn't work on my computer, I've added the output to my question. –  Adrian Matteo Jan 6 '13 at 23:43
    
I've the same problem using the M510 mouse and K750 keyboard. I'm using the modprobe script from this question and it usually gets one of the two working but both together seems to be a game of "connect the receivers until it's working", and sometimes even that doesn't work. –  ThomasH Apr 12 '13 at 11:35
    
@AdrianMatteo You do not need HIDPoint to get your Unifying device to work, it works out of the box on Ubuntu/Linux. –  Lekensteyn Apr 25 '13 at 16:35
    
@Lekensteyn Mine does not work out of the box. I've just visited the link you provided and installed the library they mention and it recognizes the usb unifying receiver sometimes, if I run ltunify list sometimes it will say Mouse M510 and sometimes "No Logitech Unifying Receiver device found". Some how the receiver is turning itself on/off "randomly" –  Adrian Matteo Apr 27 '13 at 18:27

1 Answer 1

The problem with the Unifying Receiver is likely caused by this bug: https://bugs.launchpad.net/ubuntu/+bug/958174 which apparently has been fixed upstream. No fix as of yet in Ubuntu, but in the meantime running sudo modprobe -r hid_logitech_dj && sudo modprobe hid_logitech_dj a few times will probably fix it.

The message you're seeing (Operation not permitted) is because modprobe must be run as root (the most privileged user), which can be done using 'sudo' as above.

share|improve this answer
    
You were right about the error message the second command wasn't being run as root, I've run the command several times, it works sometimes but after a few seconds it stops working. –  Adrian Matteo Jan 22 '13 at 2:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.