Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I played Lugaru, the game went in Full screen mode, but when I closed the game, the screen resolution was still 640x480. It happened with Neighbours From Hell also, using Wine, and well... Almost every game i tried in fullscreen mode. Is it normal? Is there a fix for that?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Fullscreen handling in Linux is rather broken and lots of games are causing such troubles. Easiest workaround is probably to use xrandr to bring things back into the proper resolution (put that in a script and make it an icon in the top/left corner of your screen for easy restore):

For a single monitor setup that would be simply something like:

xrandr --output DFP2 --mode "1680x1050"

For a multimonitor setup it would look like:

xrandr \
 --output DFP2 \
   --mode "800x600" \
   --panning "800x600+1280+0/0x0+0+0" \
 --output CRT1 \
   --mode "1280x1024" \
   --panning "1280x1024+0+0/0x0+0+0"

Running xrandr without any option give you a list of supported modes and available displays.

Note there is also a bug in xrandr itself, sometimes the monitor size will adjust, but the mouse movement will still be locked to the old resolution, to fix that just run xrandr a second time.

Alternatively you can also set wine to emulate a virtual desktop, this will prevent games from going fullscreen and force them to be confined to the Wine virtual desktop window. The setting available in winecfg and then Graphics->Emulate a virtual desktop.

share|improve this answer
    
Thanks! This tells me everything! –  Tibi Jan 7 '13 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.