Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have installed Ubuntu 12.10 (64bits) (3.5.0-18 kernel) on an ASUS N56VM and the ethernet card isn't working. Wireless card works okay. The card is Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 10).

I have read that there's a workaround for 12.04 but not for 12.10.

Additional Info:

$ lspci -nnk | grep -i ethernet
04:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 10)

$ ifconfig eth0
eth0: error fetching interface information: Device not found

$ ifconfig -a
lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1138 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1138 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:115837 (115.8 KB)  TX bytes:115837 (115.8 KB)

wlan0     Link encap:Ethernet  HWaddr e0:b9:a5:f9:ba:02  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::e2b9:a5ff:fef9:ba02/64 Scope:Link
          RX packets:8911 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7175 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7837367 (7.8 MB)  TX bytes:1063488 (1.0 MB)
share|improve this question
This question is a duplicate. Everything you need is explained here:… – Borislav Sabev Jan 9 '13 at 10:05
Hi, not quite a duplicate, my kernel is at, not as the solution which is on 3.5.0-18. – Lars Jan 10 '13 at 0:03
I am also experiencing the same issue on 3.2.0-35 and I was unable to solve it for now. But I've also not been able to find time for this these days. I will look into it for myself and when I have a result I will update the answer. – Borislav Sabev Jan 10 '13 at 8:50

1 Answer 1

up vote 2 down vote accepted

So the only way I managed to get this working was by compiling the alx driver.

I. Go and get the tarball from The Linux Foundation: and save it somewhere (let's say you saved it in Desktop/alx) II. Install some pakages needed for compiling:

sudo apt-get install build-essential linux-headers-generic linux-headers-uname -r

III. Unpack the tarball and compile it(This is provided that the file you downloaded is called 'compat-wireless-3.6.8-1-snpc.tar.bz2'):

cd /home/YOU/Desktop/alx

tar -xjf compat-wireless-3.6.8-1-snpc.tar.bz2

sudo su

cd compat-wireless-3.6.8-1-snpc

./scripts/driver-select alx


make install

modprobe alx

IV. Hooray you shoul have Ethernet now! :) Try: sudo ifconfig -a - you should see an eth0 inteface

share|improve this answer
Many thanks Borislav Sabev! Followed your solution, and now 'ifconfig eth0' shows the network card!! – Lars Jan 15 '13 at 22:56

protected by Community May 18 '13 at 11:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.