Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am well aware that this question has been asked about a billion times all over the Internet but so far nothing has worked for me...

I have a home server (Ubuntu Server 12.04) and a laptop (Ubuntu Desktop 12.04) connected to the same local network (both wired to my router).

What I am trying to do is to access my server from my laptop (ssh) to play HD movies (located on the server) directly on my laptop (using VLC).

It works just fine with 720p format movies, but as soon as I try with 1080p movies, it starts to lag badly.

I have tried all the usual tricks:

  • Increasing the caching value
  • Setting the option "Skip the loop filter for H.264 decoding" to "All"
  • Change the "Video output module" value

None of them worked for me. By increasing the caching value though, it actually seemed to work because it "buffers" for a while before starting the video, but after a while the movie stops and starts to "buffer" again...

Note:

If the movie is located on my laptop, it works good. Same issue with other players (Totem, MPlayer etc...)

This issue has been killing me for a while now, anybody knows how to solve this?

Thank you very much in advance.

Chris


Information about my laptop:

  • HP Pavilion dv6
  • Processor: 2.2 GHz Intel Core i7-2670Q
  • Memory: RAM 6 GB DDR3
  • Video: AMD Radeon HD 6490M (1 GB DDR5 dedicated, up to 4 GB total)
share|improve this question
    
If it's lagging on the LAN I'm guessing server side lagging. Does your setup have to do any transcoding during the streaming process? –  hbdgaf Jan 6 '13 at 16:53
    
Thanks for your answer. I actually do not have any streaming process I guess... I just connect to my server using ssh, browse through my movies and open them with VLC. So I think that VLC is only caching the time I have set, and stop the movie to redo the caching when this time is reached. I maybe should set a kinda streaming to be able to have a sort of "continuous caching" while playing. Although I have no clue how to do such a thing, any tips? –  Chris Jan 7 '13 at 9:04
    
I'ld get it to the desired format once (encode it at whatever quality you plan to view it). Don't send it over ssh, you're asking for a ridiculous amount of crypto processing overhead. Stream with the vlc rtsp streaming options. –  hbdgaf Jan 8 '13 at 0:12

1 Answer 1

Thanks "AbrahamVanHelpsing" for your replies and sorry for the delay. I have finally fixed my issue and thought it may be helpful for others as well..

After struggling I found out that nothing was wrong with my VLC setup. I could actually just have left the default settings. The problem was my connection speed...

I was convinced that it wouldn't be the issue since my router is supposed to provide up to 150 Mbps (so nearly 20 MB/s). Well, as it turned out I was wrong... I checked my connection speed by transferring a file from my server to my laptop (using the scp command line) and was amazed to see a poor 970 KB/s transfer speed.

this rate was of course not enough. To watch a HD movie over a network you need at least 2.5 MB/s.

Following this article, I understood that it is advised to reboot your home internet connection from time to time. I then restarted my router and the problem was gone! The scp transfer was progressing around 5 MB/s, letting me smoothly watch my HD movies :)

Ps: I also installed XBMC and the result is just amazing!

Thanks again for your time and I hope this thread will be useful to others.

Chris

share|improve this answer
    
You may also find that a better wireless router might be a worthwhile investment. I've been through a few and since I have had my WNDR3700 I no longer have any problems (and have not had to restart it since I moved in to my current apartment). –  neon_overload Jan 17 '13 at 6:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.