Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Ubuntu 12.10. I have Matlab 2012b installed on it.It was working fine until the last time I tried to open it.

*My Problem : * Matlab not working.The following message is displayed when I open it through terminal.I am new to ubuntu and I need help to resolve it.

terminate called after throwing an instance of 'std::runtime_error'
what():  locale::facet::_S_create_c_locale name not valid
Aborted (core dumped)
share|improve this question
    
If the problem only occurred once rebooting the computer may help. –  Dennis Jaheruddin Jan 7 '13 at 13:03
    
Thanks but I observed that there was some libraries that went missing after some updates which I have to add on separately.Now its working fine. –  user12448 Jan 11 '13 at 19:23
    
Could you please briefly describe how you did it and accept that as an answer? This may help others who encounter the same problem. –  Dennis Jaheruddin Jan 13 '13 at 11:54
    
Honestly I am not sure of how it was fixed.I took help of my friend.All I got was that some libraries related to locale were missing after some updates.They were restored again manually.I am sorry that I don't remember the exact command used. –  user12448 Jan 14 '13 at 13:17

3 Answers 3

As the asker seems to have found a solution I will post it here for him:

some libraries related to locale were missing after some updates.They were restored again manually.

share|improve this answer

I had this problem and resolved it by setting a locale explicitly in the GUI according to the instructions here, though on my build (debian 7.6) the appropriate panel item was at the top of the screen. It was then necessary to log out and back in again to make it take effect.

This assumes you have the underlying locales installed and configured properly on the base system, which you can do in a shell with

sudo dpkg-reconfigure locales

NB That same document recommends not to use the LC_ALL environment variable on the grounds that it's a high level override of all the other locale settings intended for testing purposes.

share|improve this answer

I don't know how or why, but running software updates and following this similar post's answer did the trick for me.
That is to add this environment variable...

export LC_ALL=C

Have a nice week.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.