Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't play any video content.
I keep getting errors about missing plugins. I installed the 3rd party codecs at install.

I am getting the following error

No packages with the requested plugins found

The requested plugins are:

GStreamer element ffmux_dvd
GStreamer element ffdeinterlace

When I look in Ubuntu Software centre all of the Gstreamer plugins appear to be installed and the only option is to remove them.

share|improve this question

sudo /usr/share/doc/libdvdread4/install-css.* worked for me.

With the s on the end (as in Danial Jose's answer), it wouldn't work. I replaced the s with an asterix (*) and it worked; if you have the same problem, this may fix it for you. (Tested 3 different videos in Arista, a flv, an mp4 and an webm and they all work now.)

share|improve this answer

In some countries, the use of the below unlicensed decryption software is not permitted by law. Verify that you are within your rights to use it.

Install libdvdnav4, libdvdread4, gstreamer0.10-plugins-bad, and gstreamer0.10-plugins-ugly.

If you would like to play encrypted DVDs (see the legal note above), open the Dash and launch a Terminal.

Type the following into the screen which appears, then press Enter:

sudo /usr/share/doc/libdvdread4/

Enter your password to complete the installation.

share|improve this answer
Thanks for your help but this was unsuccessful. According to Ubuntu software centre all of these packages are installed. I ran the suggested commend I get "command not found" – Ron Jan 7 '13 at 11:17
The and of the command was wrong. You can try it now. But it does not solved my problem in Ubuntu 14.04. The question should include Ubuntu version. – Arpad Horvath Feb 8 '15 at 15:57

You need to install gstreamer0.10-ffmpeg Install gstreamer0.10-ffmpeg.

share|improve this answer
Not available for my Ubuntu 14.04 LTS installation, unfortunately. – Marnix Klooster Nov 11 '15 at 9:32

I stumbled upon this that fixed my Arista transcoder that was asking me the same thing, worked for me on Ubuntu 14.4 64bit. Published on Apr 21, 2014

Solución del Problema con GStreamer elemento ffdeinterlace en Arista En Ubuntu 14.04 LTS

Abrir el Terminal

sudo add-apt-repository ppa:mc3man/trusty-media  

sudo apt-get update  

sudo apt-get install gstreamer0.10-ffmpeg  
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.