Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was installing ubuntu 12.04 to the side of windows 7 to my friends' computer when I came across the partitioning of the HDD. By accident, I selected swap as the whole partition, which I intended on using it in Linux. Now, because I have three partitions, one for windows loader (~17gb), one for windows os (and data, about 120gb) and a huge swap file (~320gb). So I couldn't install the linux but when I tried to both from live-ubuntu and from windows 7, I couldn't format the swap file to fat32 or ntfs. I tried using Disk utilites and windows' own formatting app from control panel. Each one recognizes the partition, but when I try to format it, it says an error message. Also, to top this all of, I tried all the ways in live-ubuntus Disk utilitys to format it with no success. But the thing is, when I put back the boot order to launch windows, the windows doesn't boot at all! But I had to go so I couldn't investigate the problem further, but I'm feeling pretty quilty since it might be that i ruined my friends computer...

I know my explanation seems a bit confusing, but thats because I'm not in front of the computer and I am explaining all from my memory. I would appreciate any help.

share|improve this question
    
try to delete using gparted before formatting. –  Web-E Jan 6 '13 at 11:33
    
i tried to belete it both with windows and with linuxes disk utility, does deleting with gparted differ from the disk utility and windows? –  Samuli Jan 6 '13 at 11:43
2  
Load the the live Ubuntu and open a terminal type sudo fdisk -l and add the output to your question. –  Shutupsquare Jan 6 '13 at 11:46
    
okay will do as soon as i get my hands into that computer, probably tomorrow morning, thanks in advance! –  Samuli Jan 6 '13 at 13:06
    
it seems that the computers whole hdd has been completely wiped... :o no idea how... it seems that i have to reinstall windows 7 too. disk utility shows me nothing but free 500gb space and the command sudo swapoff /dev/sda doesn't show anything –  Samuli Jan 7 '13 at 10:13

1 Answer 1

Use the command swapoff on the partition before trying to use it. Linux Live CD try to probe a swap partition and mount it while booting.

Usually the command to swapoff is

sudo swapoff /dev/sdxx

Where xx is disk and partition number (best found by sudo swapon -s (-s stands for summary)).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.