Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Windows 8 is already jnstalled in UEFI mode on an Asus g55vw laptop. Sad but true, I need it - for now.

Downloaded the last version of Ubuntu 12.10.

Made a bootable CD from the iso-file.

Reboot in EFI-mode.

BIOS -> check, ubuntu boot screen -> check

Both indicating the system is running both CD and HDD in EFI mode.

Pressing both "install" and "try" options result in 20seconds of CD and HDD operating-sounds and LEDs blinking. Then silence and a blank screen.

I would really be greatfull for some suggestions :)

share|improve this question
    
Do your BIOS have Secure Boot support. –  Arch user Jan 6 '13 at 1:13

2 Answers 2

To install Ubuntu on a UEFI computer, follow the 1st paragraph of https://help.ubuntu.com/community/UEFI

share|improve this answer

I solved the problem partly. It had something to do with my BIOS settings.

Now the installer runs through smoothly. Can't tell if dual boot works though.

Ubuntu installer offered me no choice as it didn't recognize the Windows partition.

After two days of Windows I got really annoyed anyway, so I erased the partition and am using a solo Ubuntu installation now.

@LovinBuntu: btw. I did follow the instructions. And I can confirm that my PC was running in EFI-mode. I don't know why it didn't recognize my Windows 8 partition.

But I guess we can close this thread now. Except somebody else has the same problem.

share|improve this answer
    
Hmm, well, the problem might have been that you didn't disable secure boot or whatever. askubuntu.com/questions/221835/… –  Nil Mar 31 '13 at 15:59
    
oh, here we go,directly copied from that link: "After finishing the installation, if you happen to have Windows 8 disabled from booting and it only boots to Ubuntu, do not worry. In Ubuntu after it boots, open a Terminal and type the following: sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install boot-repair Now run boot-repair" –  Nil Mar 31 '13 at 16:02
    
Upvote for warning about "not reckognize the windows partition". Same here on 13.04 - but you can keep windows by selecting the "something else" option, i.e. manual partitioning, and shrinking the windows partition. Subject to the safety issues around Windows 8 hibernation-by-default! For safety I'm guessing you need to "restart" out of windows first, instead of "shutdown". I forgot, so I mounted the windows partition and removed hiberfil.sys before booting back to windows - I don't know what would have happened otherwise but the worst case is pretty damn bad.). –  sourcejedi Apr 27 '13 at 8:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.