Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can play video on the youtube website, but I cannot play youtube videos embedded in facebook or other websites. Captchas are also not showing up, I suspect the two problems are really the same problem. This started about a week or two ago.

share|improve this question
No such problems are present when using Chromium. I already tried uninstalling and reinstalling firefox. – user87317 Jan 5 '13 at 23:41
up vote 3 down vote accepted

"... I already tried uninstalling and reinstalling firefox."

Uninstalling and reinstalling is mostly a waste of time for problems with your browser. You should look at these two references:
Troubleshoot Firefox issues using Safe Mode
Use the Profile Manager to create and remove Firefox profiles

Problems with browsers commonly arise because of

  • some extension/plug-in the user installs or removes or which is updated or which stops working after an update to Firefox.
  • corruption of some aspect of the user's profile.

To elaborate, whether an add-on or plug-in is responsible for your problem, a "safe mode" is available and its usage is detailed in the first link.
A corruption of some file, a relatively rare situation, can be deduced by using a different profile as described in the second link.
Note that backing up your valuable data such as bookmarks is a must.

share|improve this answer
Disabling Google Disconnect 2.4.2 add-on. This is not really the perfect solution since I am now without Google Disconnect. Is there an easy fix for this? – user87317 Jan 7 '13 at 19:36
I don't use it but from what I read the extension blocks trackers. This can be disruptive as you are seeing. If the extension provides you an interactive interface that shows the trackers it blocks, you could, perhaps, pick and choose which ones to block and which to allow. – user25656 Jan 8 '13 at 2:40

It turned out that the culprit was the Google Disconnect 2.4.2 add-on. Disabling it fixes the problem. I am using Firefox 17.0.1.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.