Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Acer EEE PC with SSD drives and ubuntu 10.10. It works fine - most of the time - but after boot or io-intense operation (copying file, installing updates, etc...) load increases to 2, stays for a few minutes and slowly decreases back to 0.5 or so.

How I can confirm source of the problem? Is it SSD drives, software, drivers, something else? Any way to fix?

share|improve this question
    
Old question :-) –  guntbert Nov 1 '13 at 21:10

2 Answers 2

up vote 1 down vote accepted

You could try the workarounds I already provided in this thread:

I noticed awful freezes during IO operations as well. While I can't tell why this is happening, I can offer a workaround. Here's how:

In a terminal, type

echo "deadline" | sudo tee /sys/block/sda/queue/scheduler

Try moving or copying larger ammounts of files again. You should notice a huge difference. If so, make the change permanent by typing in a terminal:

gksudo gedit /etc/default/grub

In the line beginning with GRUB_CMDLINE_LINUX_DEFAULT="", add the following string in between the ""s:

elevator=deadline

Save and exit. After that, type in a terminal

sudo update-grub

Reboot.

FYI: This changes the so-called scheduler to 'deadline'.

Source: http://techtitbits.com/2010/04/get-rid-of-freeze-ups-during-disk-io-activity-in-ubuntu/

================================================================================

Another Possibility would be to lower dirty_ratio settings. To test it, type in a terminal:

sudo bash -c "echo 10 > /proc/sys/vm/dirty_ratio"

sudo bash -c "echo 5 > /proc/sys/vm/dirty_background_ratio"

If this helps, make it permanent by editing your sysctl.conf:

gksudo gedit /etc/sysctl.conf

At the end of the file, add the following lines:

vm.dirty_ratio=10

vm.dirty_background_ratio=5

Save, close and reboot. Done.

share|improve this answer

Are you using Ubuntu One? I'm experiencing similar problems with U1 after boot.

You can try opening System Monitor (should be under System > Administration) at boot and see if ubuntuone-syncdaemon (or another program) is hogging the hard disk. Or better yet, download a program called iotop, and run it from Terminal right after boot. It'll show which program is responsible for the high I/O wait.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.