Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 12.10 64 bit. Compiz crashed just after I changed a setting in touchpad section (I didn‘t even have the ccsm installed). Now I am getting a blank screen without title bar, etc - only mouse is working. Alt-F2 also doesn‘t work. The same thing happens with guest account also. I‘ve also tried restarting multiple times.

On tty1(ctrl-alt-f1), I tried running

DISPLAY=:0 compiz --replace
DISPLAY=:0 compiz --reset

DISPLAY=:0 unity --replace
DISPLAY=:0 unity --reset

None has worked so far. The first two commands give the error: Invalid MIT-MAGIC-COOKIE-1 keycompiz (core) - Fatal: Couldn‘t open display :0 or sometime just hang.

unity --replace just hangs after giving a lot of Plugin init failed errors alongwith Error: Plugin ‘opengl‘ not loaded and unity --reset says reset is deprecated.

I also don‘t see any ubuntu logo beside the username, so I am unable to login in unity 2d.

I have AMD HD 7730m and I was not able to install the proprietary driver before the crash.

share|improve this question
1  
Hi, can you explain how you got to the touchpad section or in what app that section is located. That can give us an idea as to what file to edit in the terminal to go back to the previous configuration that worked. –  Luis Alvarado Jan 5 '13 at 22:28
    
I had enabled “2-finger scrolling“ in mouse and touchpad settings. –  Koderok Jan 6 '13 at 4:20
1  
Wow, well I don't think then that will be the problem. Can you get to the GRUB Menu and select recovery mode? –  Luis Alvarado Jan 6 '13 at 5:02
    
well, actually this is another problem. At the grub screen I dont see the boot options - just a blank screen which automatically boots to ubuntu after a few seconds :) –  Koderok Jan 6 '13 at 6:49
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Mar 1 '13 at 1:19
add comment

closed as off topic by Jorge Castro, hexafraction, Seth, Uri Herrera, raaz Mar 2 '13 at 13:46

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.