Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to install software or upgrade from old unsupported release?
How can I fix a 404 Error using the Ubuntu archives?

While trying to upgrade, I got this error. Has anyone seen it before? Please advise me on what to do! Thank you!

W:Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/main/source/Sources.gz  404  Not Found
W:Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages.gz  404  Not Found
E:Some index files failed to download, they have been ignored, or old ones used instead.
share|improve this question

marked as duplicate by Jorge Castro, fabricator4, Ringtail, Tom Brossman, Eliah Kagan Jan 6 '13 at 8:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Don't worry yourself over fetching files from 11.04 if you're upgrading to 12.04. What the error is telling you is that it's unable to fetch files from 11.04 and old files are being used. Are you able to upgrade to 12.04? –  etsr Jan 5 '13 at 21:08

1 Answer 1

These are 'extras' for Ubuntu 11.04 ('Natty').

This release reached end-of-life recently, and is no longer supported for security and other updates.

See: Ubuntu 11.04 (Natty Narwhal) reaches end-of-life on October 28, 2012

If you need to be using a long-term-support release, you should be using 12.04 LTS (or possibly 10.04 LTS on very old equipment).


If you are currently using 11.10 (Oneiric):

Is there any reason you still have Natty-specific resources in your setup? Otherwise, removing these two lines will solve this error.


If you are still on 11.04 (Natty):

You should not be attempting to upgrade directly to 12.04, but instead first upgrade to 11.10.

Note: As you have not already done so, and may not be up-to-date, it would be better to do a clean install of 12.04 LTS instead (after backing-up all settings and user data). Any issues you may have with upgrading from 11.04 are not supported, as 11.04 is no longer supported.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.