Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How can I install software or packages without Internet (offline)?
BCM4311 Wireless Not Working with Drivers Installed

I've already put some effort in finding a solution to my WiFi issue, yet all I've found is about connecting to the internet in an alternative way first. However, I'm unable to do so, as my wired network card does not work either.

brief background

Previously, I owned a Dell XPS laptop on which I was running Ubuntu 12.10 64-Bit. Now I got a new (second hand) machine, a Dell Vostro 1500 and decided to just take the hard drive from the XPS and put it in the Vostro, rather than having to reinstall Ubuntu.

All appears to be working, except for the wireless driver. The previous owner of the Vostro went with the Broadcom, unfortunately. Worse yet, the wired ethernet adapter/port appears to be fried so I currently have no Internet access at all.

about my attempts

If I launch "software sources" & "Additional Drivers", it identifies an option for Broadcom 802.11 Linux STA Wireless driver Source for the BCM4311. However, directly below the option it says "This device is not working". I had assumed that was because I simply needed to install the proprietary drivers (still mostly think that). However after I try to enable it, I get a progress bar for installing it that stops part way through and then the "Do not use the device" option is reselected.

I have the install media but have been unable to figure out how to get the system to extract the driver from it (assuming internet only install?).

The only thing I have not yet tried was purchasing a USB style connecter & attempting hook into ISP modem/router via USB based connection. I would rather not deal with it if there is an easier method using a few commands and/or file I can download form another machine.

So, is there a way I can get this driver installed without having internet access?

I feel my technical knowledge/comprehension is above "noob", but below proficient - so I like detailed steps when possible.

I'd really appreciate some help on this!

share|improve this question

marked as duplicate by Jorge Castro, gertvdijk, Ringtail, Luis Alvarado, Eliah Kagan Jan 6 '13 at 7:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

connect your pc using ethernet cable and go to dash home on the top left. Type "additional driver". Click the first option and install it. – Rorschach Jan 5 '13 at 18:34
@rafiki You must have missed "Worse yet, the ethernet adapter/port does not work" deeply burried in the background story I've now compacted. – gertvdijk Jan 5 '13 at 18:58
When you plug the ethernet cable in, do you get a light on the router and the port (if it has one) ? I've just had a case where ACPI IO conflicted with the on-board ethernet controller (lights were on, but no-one was home). The port may not actually be fried. If there's a conflict it may appear in the log. Try "cat /etc/log/syslog | grep conflict" or have a look at this file for any other problems. – fabricator4 Jan 6 '13 at 0:10
@Jorge Castro : the indicated dupe is not helpful I'm afraid. OP needs a solution that does not use an ethernet connection since it isn't working on that either. Possible helpful solutions: give instructions for install module from files only, or possibly getting the ethernet working. – fabricator4 Jan 6 '13 at 0:13

First purge & remove existing broadcom packages.

The downloading part,

You can do it with help of print-uri feature of apt-get.

First you need to determine the package name for example say for braodcom you need b43-fwcutter. (This is just example)

Next execute the command,

sudo apt-get --print-uris --yes --reinstall install b43-fwcutter | grep ^\' | cut -d\' -f2 > b43-fwcutter.txt

This will produce the dependent links to the text file. Do this for all the packages required.

Now pass the file in another computer using wget (you can pass a file to wget to download all links using wget --input-file filename.txt) or any other download manager(if in windows) to download the packages.

Once done, copy all the deb packages to your target computer. Open a terminal, navigate to the directory using cd, and use sudo dpkg -i *.deb

share|improve this answer
+1 This is a great suggestion if the steps are just about installing some packages. It's terrible if it concerns packages with loads of dependencies, however, it's not clear what exact instructions the OP needs to run. – gertvdijk Jan 5 '13 at 20:52

Two options I see to go from here:

  1. Install the drivers on your installation using another machine.

    Put the hard drive in another machine (with network/internet) and run the steps towards your solution from there. Unlike Windows driver installations, you don't need hardware to install the support for it.

  2. Find alternatives to get connected and be creative, e.g. using an USB wired network adapter or an alternative working WiFi adapter borrowed from a friend or neighbour.

    I suggest to buy one of these. Fairly cheap and a good tool to add on your toolchain.

    enter image description here

share|improve this answer
As previously stated, the eithernet port does not work. What I should have said for clarification is that it appears to be fried as it did not work for previous owner using XP (stopped working). I have tried it hoping it was an OS disabled thing as opposed to fried. But it still does not work. Because it is a laptop, simply plugging in an adapter does not appear to be an option unless of course i can hunt down a USB device. Based on the comments, it looks like I will have to find a way to get it online some how. Thank you all. – R. Potter Jan 5 '13 at 19:43
@R.Potter My answer is targeted towards your situation. I am aware your integrated ethernet cards is not working. What about my answer is not clear about that? The first options is circumventing the whole laptop. – gertvdijk Jan 5 '13 at 20:23
My apologies. I had not seen the graphic previously and also believe I thought I was responding in general as apposed to your post specifically. Ironically, I found the exact device you have pictured. Have no clue how the heck I even had it let alone found it. Either way, it works. I was able to update the driver & Ubuntu now indicates that driver is the active driver. Sadly, the wireless is still not working. It appears it is not being activated (switch on laptop does nothing). Anyhow, initial problem solved. Thank you all. – R. Potter Jan 5 '13 at 20:39
@R.Potter No problem. I just added the image, though (you can edit posts here, like I did with your Q). Refer here for further issues: My WiFi adapter is not working at all. Where to start troubleshooting? in the part about rfkill as it sounds like a killswitch issue now. – gertvdijk Jan 5 '13 at 20:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.