Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to shrink partition from this:

original partitioning

To this:

desired partitioning

As you see, I booted from Live CD and used GParted. When I apply the changes, it works some time and then fail with message:

resize2fs: Attempt to read block from filesystem resulted in short read while trying to resize /dev/sda1
Please run 'e2fsck -fy /dev/sda1' to fix the filesystem
after the aborted resize operation.

If I run that command, I get the following output:

/dev/sda1: 301319/30277632 files (0.4% non-contiguous), 21492778/121104896 blocks

What should I do?

share|improve this question
2  
Did you do as it asked? e2fsck -fy /dev/sda1 –  Shutupsquare Jan 5 '13 at 16:46
    
yes, tried 2 or 3 times. Trying again. –  charlag_khan Jan 5 '13 at 16:48
    
it says: /dev/sda1: 301319/30277632 files (0.4% non-contiguous), 21492778/121104896 blocks –  charlag_khan Jan 5 '13 at 16:50
1  
It's possible that there are some badblocks in your filesystem. This command will find them: e2fsck -c /dev/sda1 (it will take some time to complete). –  Andrea Corbellini Jan 5 '13 at 17:06
    
Sounds like you might have a failing hard drive run the hdd manufacturers tests. –  Shutupsquare Jan 5 '13 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.