Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

while installing gstreamer I get following error:

gstreamer0.10-plugins-bad: Depends: libass4 (>= 0.9.7) but it is not going to be vinstalled

                       Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.3 is to be installed
                       Depends: libcairo2 (>= 1.2.4) but 1.10.2-6.1ubuntu3 is to be installed
                       Depends: libcdaudio1 (>= 0.99.12p2) but it is not going to be installed
                       Depends: libcelt0-0 (>= 0.7.1) but it is not going to be installed
                       Depends: libcurl3-gnutls (>= 7.16.2-1) but 7.22.0-3ubuntu4 is to be installed
                       Depends: libdca0 but it is not going to be installed
                       Depends: libdirac-encoder0 but it is not going to be installed
                       Depends: libdirectfb-1.2-9 but it is not going to be installed
                       Depends: libdvdnav4 but it is not going to be installed
                       Depends: libdvdread4 but it is not going to be installed
                       Depends: libfaad2 but it is not going to be installed
                       Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
                       Depends: libglib2.0-0 (>= 2.31.8) but 2.32.3-0ubuntu1 is to be installed
                       Depends: libgme0 (>= 0.5.5) but it is not going to be installed
                       Depends: libgsm1 (>= 1.0.13) but 1.0.13-3 is to be installed
                       Depends: libgstreamer-plugins-bad0.10-0 (= 0.10.22.3-2ubuntu2.1) but 0.10.22.3-2ubuntu2.1 is to be installed
                       Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.36) but 0.10.36-1ubuntu0.1 is to be installed
                       Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.36-1ubuntu1 is to be installed
                       Depends: libkate1 (>= 0.4.1) but it is not going to be installed
                       Depends: libmimic0 but it is not going to be installed
                       Depends: libmms0 (>= 0.4) but it is not going to be installed
                       Depends: libmodplug1 but it is not going to be installed
                       Depends: libmpcdec6 (>= 1:0.1~r435) but 2:0.1~r459-1ubuntu1 is to be installed
                       Depends: libofa0 (>= 0.9.3) but it is not going to be installed
                       Depends: libopenal1 (>= 1:1.13) but 1:1.13-4ubuntu3 is to be installed
                       Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                       Depends: libpng12-0 (>= 1.2.13-4) but 1.2.46-3ubuntu4 is to be installed
                       Depends: librsvg2-2 (>= 2.14.4) but 2.36.1-0ubuntu1 is to be installed
                       Depends: librtmp0 (>= 2.3) but 2.4~20110711.gitc28f1bab-1 is to be installed
                       Depends: libschroedinger-1.0-0 (>= 1.0.9) but 1.0.11-1 is to be installed
                       Depends: libslv2-9 (>= 0.6.4-1~) but it is not going to be installed
                       Depends: libsndfile1 (>= 1.0.20) but 1.0.25-4 is to be installed
                       Depends: libsoundtouch0 but it is not going to be installed
                       Depends: libspandsp2 (>= 0.0.6~pre18) but it is not going to be installed
                       Depends: libssl1.0.0 (>= 1.0.0) but 1.0.1-4ubuntu5.5 is to be installed
                       Depends: libstdc++6 (>= 4.1.1) but 4.6.3-1ubuntu5 is to be installed
                       Depends: libvo-aacenc0 (>= 0.1.0~rc1) but it is not going to be installed
                       Depends: libvo-amrwbenc0 but it is not going to be installed
                       Depends: libvpx1 (>= 1.0.0) but 1.0.0-1 is to be installed
                       Depends: libwildmidi1 (>= 0.2.3) but it is not going to be installed
                       Depends: libxvidcore4 (>= 1.2.2) but it is not going to be installed
                       Depends: libzbar0 (>= 0.10) but it is not going to be installed
                       Depends: libzvbi0 (>= 0.2.11) but it is not going to be installed

and with vlc ...

vlc:Depends: vlc-nox (= 2.0.3-0ubuntu0.12.04.1) but 2.0.3-0ubuntu0.12.04.1 is to be installed

 Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.4ubuntu0.12.04.1 is to be installed
 Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.4ubuntu0.12.04.1 is to be installed
 Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.3 is to be installed
 Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.3 is to be installed
 Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.3 is to be installed
 Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
 Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
 Depends: libtar0 but it is not going to be installed
 Depends: libxcb-keysyms1 (>= 0.3.8) but it is not going to be installed
 Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed
share|improve this question
    
sudo apt-get install -f for dependecy errors. –  nickanor Jan 5 '13 at 15:12
    
Well you've got one hell of a mess there, what did you tried to install?. –  Uri Herrera Jan 5 '13 at 17:19
    
You are running 12.10 correct? –  Seth Feb 4 '13 at 19:21
    
Welcome to Ask Ubuntu! Please provide the output of apt-cache policy (lists all sources configured) and have you run sudo apt-get update before you tried to install? –  gertvdijk Feb 4 '13 at 19:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.