Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed all the instructions reported here: http://www.omgubuntu.co.uk/2011/12/how-to-connect-your-android-ice-cream-sandwich-phone-to-ubuntu-for-file-access/ in order to connect my Android ICS phone to Ubuntu.

I restarted my system before trying to acces my phone, and I get this output when trying to mount it:

Listing raw device(s)
Device 0 (VID=1004 and PID=631c) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   1004:631c @ bus 2, dev 2
Attempting to connect device
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0

Any advice on how to solve this problem?


Thanks to Buzz-Dee I followed these instructions to update gvfs. The problem now is solved by using go-mtpfs. Still not working automatically when connecting the phone, but I think I can survive without it ;)

share|improve this question
Try this: webupd8.org/2012/12/… –  Alin Andrei Jan 9 '13 at 13:35
Not working, still not recognised and this time with a different error: 2013/01/09 18:09:20 No storages found. Try unlocking the device. –  dadexix86 Jan 9 '13 at 17:17
try this: Connecting Galaxy S3 (I747) to Ubuntu 12.04. –  BuZZ-dEE Jan 30 '13 at 16:22
@BuZZ-dEE No! Now I tried and it works! Many thanks!! :D –  dadexix86 Feb 2 '13 at 20:46
No, go-mtpfs worked fine for me, but only after following your instructions to update gvfs :) –  dadexix86 Feb 3 '13 at 13:17
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.