Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to ask for tips why shortucts f.e. for build F9 or compile F8 are not working in Geany text editor.

I tried to assign different shortcuts including Ctrl+F8 or Ctrl+Shift+B and none of them worked.

share|improve this question
    
Have you got multimedia keys enabled in the BIOS? Check if CTRL+ALT+F2 takes you to the command line (ALT+F7 to get back.) –  James Jan 5 '13 at 10:53
    
Yes, CTRL + ALT + F2 takes me to terminal. –  Betlista Jan 5 '13 at 16:47
    
Can you assure these are not cached by your operating system or desktop environment? Which system are you using? What were you trying to assign? –  user135464 Feb 25 '13 at 11:01
    
Are you still experiencing this problem? You never replied to the comment above. –  Seth May 11 at 16:49

3 Answers 3

I observe that this only happens after accidentally pressing the shortcuts in the VTE (the embedded terminal). Even after switching focus back to the main editor, these shortcuts still do not work.

To fix, go to Edit -> Preferences -> Terminal, then uncheck the "Override Geany keybindings" option. However this will disable all keybindings for the terminal, including Ctrl+C for SIGINT. If you don't want that, you'll have to restart Geany everytime it doesn't work.

This bug has been filed here, but it was closed as "won't fix". It seems to be affecting Unity only, and to quote Lex Trotman,

This is a Unity bug and not something we can fix.

I reported this on Launchpad.

share|improve this answer

Some keyboards (like Microsoft's Digital Media Keyboard 3000) requires Fn lock to use the "F*" keys. Perhaps it is due to that.

share|improve this answer
    
I tried that, but it's not working. I have installed Ubuntu on my Acer notebook (so I have standard), NB keyboard. I do not use en keyboard layout, but I tried with that too, but still not working. –  Betlista Jan 5 '13 at 16:52

It may help to make sure your source code files are named with the correct file extension.

I'm using the editor for Pascal, so in my case it helped to add the .pas extension to the file-/project name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.