Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I have a Windows 8 PC with two monitors attached:

  • A 24" primary monitor at 1920 x 1200, and
  • A second 19" monitor at 1280 x 1024.

Windows boots using the smaller 19" monitor before eventually adopting the saved configuration: 24" as primary, 19" as secondary. Ubuntu does more or less the same, booting on the 19" then using both monitors.

After Ubuntu installation the desktop is mirrored across both. I switch this option off and then set up the correct resolutions. I then adjust the position of the monitors using the utility provided. Everything is good and lovely. However, the next time I fire up Ubuntu (restart or cold boot) the settings have been lost and something else is adopted. That is doesn't seem consistent.
Sometimes it will confuse the 24" unit and result in a display that, whilst reported to be 1920 x 1200 - is way off the screen by some distance. What's worse, sometimes the displays are completely corrupt and there is no choice but to physically reset the computer.

I really want to get this working so any help would be welcome.

For reference my specifics are listed below:

  • My graphics card is a GeForce 9500GT,
  • The BIOS 62.94.80.00.00 and Win 8 Drv:9.18.13.0697,
  • The Monitors are:
    • Acer AL2416W (analog input only), and
    • A Viewsonic VG910b (Digital input used),
  • The motherboard is Gigabyte 965P-S3,
  • The CPU is E6420 Core 2 Duo,
  • 4GB of RAM.
  • Ubuntu ISO is 12.10-desktop-i386.iso installed alongside Windows 8. I am using the default desktop.

Incidentally, Ubuntu correctly identifies each monitor when using the display settings utility but doesn't automatically select the native resolution for the 24" unit. This has to be manually selected from the drop down list.

share|improve this question
add comment

1 Answer 1

It's quite possible that you aren't starting up your monitor settings with admin rights. Try bringing up the terminal (Ctrl + Alt + T) and typing the following:

sudo gnome-control-center display

(After this, you'll put in your password and press enter)

share|improve this answer
    
Since you say you're a new user, I'll explain what all those steps are... The Ctrl+Alt+T brings up the terminal. The Terminal is where you can put in commands straight to Ubuntu, getting past the friendly candy coating you normally deal with. (It's like opening the hood of your car instead of just messing with the steering wheel and gas and brake pedals.) When you begin typing, the sudo command at the beginning (short for super-user do.) says "I'm in charge, don't tell me what I can't do." Gnome-control-center is the settings program and the display is the specific part you're running. –  liljoshu Jan 5 '13 at 10:24
1  
Thanks for this. I followed the instructions carefully but get the following error: Failed to apply configuration: %s GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.SettingsDaemon.XRANDR_2' on object at path /org/gnome/SettingsDaemon/XRANDR –  Mark G Jan 5 '13 at 15:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.