Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason, I am unable to perform the

:set mouse=a

command in vim. I have installed pretty much every vim related package from apt that seems applicable. Vim version is 7.3 (Huge version with GTK2-GNOME GUI). +X11 is included.

This is a new workstation, with a previously installed version of ubuntu (that I can't change, because this is a work computer). I've never had a problem with this in the past, and have other machines where this works fine, running 12.04, 12.10, and older versions of Ubuntu. Any help is much appreciated.

share|improve this question
    
What happens when you issue that command? Do you get an error? –  guntbert Jan 4 '13 at 22:08
    
nope. no error. just doesn't do anything. can't move window borders, selection includes line numbers, etc. –  Bennidhamma Jan 5 '13 at 0:12
1  
Strange, I have one idea left: try to play with set ttymouse=xterm2 (Must be one of: xterm, xterm2, netterm, dec, jsbterm, pterm) –  guntbert Jan 5 '13 at 17:06

1 Answer 1

guntbert's advice solved the problem. All that was necessary was to issue this command:

:set ttymouse=xterm2
share|improve this answer
    
@RickGreen-Turbo When the "thanks" answer is posted by the OP and it is responding to a comment, the best thing to do is usually not to delete or flag it, but to edit it so it's an answer. –  Eliah Kagan Jan 7 '13 at 0:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.