Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing XFCE on my ubuntu system, I tried enabling compiz with:

compiz --replace ccp &

However, I have since been unable to remove compiz from the XFCE login. I tried killing compiz, and now I don't have any window manager, and opening the "Window Manager" and "Window Manager Tweaks" pages in the settings panel brings me to an empty page.

Since I've never really played around with XFCE much I have no idea what window manager it uses. So I don't know how to phrase reverting it to the old one.

How can I revert back to the old manager?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

After installing XFCE on my ubuntu system, I tried enabling compiz with:

compiz --replace ccp &

Why did you added ccpand not just compiz --replace?

However, I have since been unable to remove compiz from the XFCE login. I tried killing compiz, and now I don't have any window manager, and opening the "Window Manager" and "Window Manager Tweaks" pages in the settings panel brings me to an empty page.

Yes, because you're not running XFWM4 which is the XFCE window manager.

Since I've never really played around with XFCE much I have no idea what window manager it uses. So I don't know how to phrase reverting it to the old one.

How can I revert back to the old manager?

Uninstall Compiz and go to Settings>Session and Start up>Application Startup and add an entry for xfwm4 --replace.

share|improve this answer

Install the fusion-icon, then run it in terminal by just typing it's name and it will show you an icon in the toolbar. Click it and select window manager. Tell me if you have any problems. The default window manager called xfwm4. xfwm4 --replace

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.