Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sennheiser MM100 bluetooth stereo headset (using A2DP) I'd like to use on my Lubuntu machine. The headset works fine with my phone.

Please note that unlike all other Ubuntu flavours, Lubuntu does not come with Pulseaudio.

It is detected by Lubuntu's Blueman Bluetooth configuration application and I can establish a connection successfully. It also appears to actually communicate as it shows data being sent back and forth. However, Sound keeps coming out of the loudspeakers only, while the headset remains silent. I would have expected the sound to come from my headset at this point.

Where do I start troubleshooting here?

share|improve this question
    
What Bluetooth adapter are you using on your PC? –  gertvdijk Jan 5 '13 at 22:31
    
My BT adapter is a Trust 17772 with BT 3.0. I did not mention that in the question because I have already made a sound streaming connection between these 2 devices, on the same PC but under Debian, but I can't remember how I managed. Also, this BT adapter connects fine to other devices and BT services under Lubuntu, so I figured there has to be a piece missing from the pulse audio side :-) –  Bennypr0fane Apr 14 '13 at 23:07

3 Answers 3

up vote 3 down vote accepted

EDIT: So I finally got this working: 1) To make Pulse Audio support A2DP, this package needs to be installed: pulseaudio-module-bluetooth. But after that it's still not easy to make it work:

2) Gnome Bluetooth applet vs. Blueman: - I have not been able to make this work reliably with Blueman, but I found that it does with GNOME BLUETOOTH APPLET. I came across this solution when I decided to use Gnome Shell (3.4 at first) on my Lubuntu, which of course came with the Gnome Bluetooth applet (package name: gnome-bluetooth: If you decide to install it without the Gnome Shell, note that it will pull some gnome libraries it needs to work). - I removed the troublesome Blueman and paired the devices via the Gnome applet, which led to successfully streaming A2DP, Pulseaudio via Bluetooth. For this to work, BLUEMAN HAS TO BE REMOVED, else it will take control of managing all bluetooth connections. When I upgraded my Lubuntu installation from 12.04 to 13.04, Blueman was reinstalled and did just that, and things started working again after I removed it.

3) After installing it (I did via Synaptic) I restarted PA

pulseaudio --kill
pulseaudio --start

but that may be unnecessary, try it in case you experience problems at first.

4) To make the connection with the Sennheiser headset, I need to put it in PAIRING MODE by turning it on and holding down the on/off button for a bit longer, till the LED flashes red and blue (as opposed to connection mode - rapid blue flashing - that would usually suffice for connecting the headset to a host device that already knows it: that doesn't work). Then, in Gnome applet (it should remember the headset after first pairing), click the "connect" button for the Sennheiser M100 .

5) You may have to go into Audio Settings and select the M100 as output device, but I get audio through the headset and not the speakers even if the system soundcard is still selected.

Hope this works for you, too, but still: When you buy bluetooth hardware for use with your Ubuntu (or derivative) system, try and find something with explicit Linux support, preferably open drivers!

share|improve this answer
    
btw the Gnome bluetooth applet is also the explanation, why it worked in Debian, which was running only with Gnome Shell in the first place. –  Bennypr0fane Sep 12 '13 at 14:28
    
this helped me, but additionally I edited the file /etc/bluetooth/audio.conf as described in askubuntu.com/questions/287254/… –  cuichi Sep 15 '13 at 18:56

Note about the answer here - It appears that Lubuntu comes without Pulseaudio and I assumed Pulse is needed for A2DP to work and that OP would have installed it. It appears not to be the case. The answer below is about a Pulseaudio installation.


Make sure you've selected the right output sink for the application you're expecting sound from.

Similar to my answer in a similar question, start by installing and starting pavucontrol and check:

  • In the Output Devices tab

    • Check the presence of your Bluetooth device. I assume it's listed there stating you see it in another application.
    • Check the obvious settings for that entry.
  • In the Configuration tab

    • Check the audio profile. Make sure you've selected A2DP rather than 'headset' or 'off' (unless you want to, really).
  • In the Playback tab the application producing sound should be listed.

    • Try to see what output sink is selected and verify it is using your Bluetooth connection.
    • Check the output volume and mute status of this particular audio stream.
share|improve this answer
    
You forgot to mention that pavucontrol requires installing Pulse Audio. The headset shows in Lubuntu default bt manager (Blueman), but not in Pavucontrol. The only output device available there is my soundcard. Also, in Blueman, 3 services are available: headset, audio sink, and input device. If not one of these is A2DP (I don't know), that means that A2DP is missing. –  Bennypr0fane Jan 5 '13 at 22:24
    
@Bennypr0fane If you've set it up without using Pulseaudio, then this is a very unusual way I don't know of. Please share how you do this without Pulseaudio in your question. Googling around for Blueman and A2DP show PA-only tutorials. Your updated comment indicates you've not set up Bluetooth fully with audio support. –  gertvdijk Jan 5 '13 at 22:25
    
@gertdvdijk: Pulse Audio is not present in a default install of Lubuntu, only Alsa. I've been managing the bt connection via Blueman. I added Pulseaudio and Pavucontrol later, I just meant that if you mention pavucontrol, you should also say it requires Pulseaudio (it's not obvious if you don't know what the name stand for) –  Bennypr0fane Jan 5 '13 at 22:31
    
I dind't know additional measures were required for full bt audio support. What are the steps needed to get full audio? –  Bennypr0fane Jan 5 '13 at 22:38
    
@Bennypr0fane Google results about wheter Lubuntu ships with or without Pulse are contradicting. I believe you don't have it, so I added that to your Q. I'm getting unsure about posting answers on Lubuntu now on this part... (sorry) –  gertvdijk Jan 5 '13 at 22:43

I made it work the following way :

Before going further :

  • Update your system (I'm running 13.10)
  • Remove blueman
  • Install pulseaudio-module-bluetooth, pavucontrol (Utility to set up pulseaudio) and make sure bluez is installed
  • Remove any "Disable=Socket" or "Enable=Socket" entry in file /etc/bluetooth/audio.conf (edit with sudo)

Steps :

  1. Put device in pairing mode (even if already paired)
  2. Pair the device with your system using default bluetooth manager (blueman should have been removed) or if already paired go to step 3
  3. Select A2DP or Audio Sink connection for the paired device. If it fails try "sudo hciconfig hci0 reset" (where hci0 is your bluetooth device) check scan is ok with hcitool scan then retry this step (do hciconfig -piscan to identify your bluetooth device)
  4. With pavutools, select a2dp in "configuration" tab and your device in "Playback" tab / If a2dp is not selected, try "pactl list cards short" to get your device id (1,2,3..) then do "pactl set-card-profile X a2dp" where X is your device id
  5. If it fails, restart avahi-daemon / bluetooth service and reset device through hciconfig hci0 reset. Check if scan is ok with hcitool scan. Then do steps 3 and 4
share|improve this answer
1  
Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. –  RolandiXor Dec 16 '13 at 19:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.