Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following the step-by-step guide on how to develop an Ubuntu Phone application but Qt Creator throughs the error message (module "QtQuick" version 2.0 is not installed) when I run it with QMLscene. Seems to me that Qt Creator utilizes Qt4 instead of Qt5. How can I fix this?

share|improve this question
    
I have the same problem when running from Plasma (with a Plasmoid). Can anyone help me ? –  Yves May 25 '13 at 18:03

4 Answers 4

You are using qmlviewer when you should be using qmlscene. Quote from the tutorial:

To start QML applications, either during the prototyping or final stages, you will use QML Scene. QML Scene is a command-line application that interprets and runs QML code.

...

Here's a tip: although Qt Creator does not yet support qmlscene as QML viewer, you can invoke it from within the IDE. Here’s how:

  1. In Qt Creator, go to Tools > Options…
  2. Choose the External Tools tab, then in the pane select the Preview (qmlviewer) entry
  3. On the Executable: field on the right, replace the contents with /opt/qt5/bin/qmlscene.
  4. Optionally change the command name by double-clicking on the Preview (qmlviewer) entry from above. You can call it Preview (qmlscene).
  5. Click on OK to save the changes.

You can also run QML Scene from the command line:

$ qmlscene /path/to/application.qml
share|improve this answer
1  
Seems that some stuff is missing on my 12.10. Directory /opt/qt5/bin/ does not exist. The only folder is /opt/qt5/imports/. How can I install the whole qt5 pack? –  Ralf Hersel Jan 5 '13 at 15:47
    
Are you sure you've followed the instructions on the Ubuntu website fully? Running sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-beta1 && sudo apt-get update && sudo apt-get install qt5-meta-full && echo 'export PATH=/opt/qt5/bin:$PATH' >> ~/.bashrc should create the directory /opt/qt5/bin. –  The Rainbow Unicorn Man Jan 15 '13 at 6:53

The Ubuntu Phone SDK does indeed use Qt 5, which you need to install yourself. That's because Qt 5 is brand new and not in the repositories yet. Steps to install it yourself are given here: http://developer.ubuntu.com/get-started/gomobile/#step-get-toolkit.

share|improve this answer
    
That's exactly what I did. I followed the guide step-by-step. Here is a screenshot of QtCreator with the App running but incomplete: ubuntuone.com/1qJHsJxyWq0RH3yvEvQ6ME –  Ralf Hersel Jan 4 '13 at 17:10

Hi~ I had the same problem like yours that Qt Creator throughs the error message

(module "QtQuick" version 2.0 is not installed).

And I was also following the step-by-step guide just like you. Finally I have fixed it now. http://ubuntuone.com/1qJHsJxyWq0RH3yvEvQ6ME this image shows that you have something wrong in configuration the qmlscene. I also had configured the qmlscene, but it had the same error like you had done.

Finally I found that when I configured the path of qmlscene , I had typed a backspace before the "/opt/qt5/bin/qmlscene" . So it didn't work. I just want to tell you what I've done to cause this error. :)

share|improve this answer

You will also have to change the default qmlviewer:

  1. In Qt Creator go to: Tools -> Options -> Environment
  2. Choose the External Tools tab, then in the panel select the Preview (qmlviewer) entry
  3. On the Executable: field on the right, replace the contents with /opt/qt5/bin/qmlscene or /usr/bin/qmlscene (in Ubuntu 12.10).
share|improve this answer

protected by Community Jan 12 '13 at 21:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.