Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a newly bought Amazon Paperwhite, but when I connect it to my PC, Ubuntu does not recognize it.

What can I do?

share|improve this question
2  
Read Managing Kindle Fire with on 12.04 via Micro-USB . I think your problem is the same. –  Antigona Jan 4 '13 at 16:14
    
What firmware version for Kindle Paperwhite? eg. 5.3.1 (My own device does connect to 12.04.) –  david6 Jan 24 '13 at 9:38
    
@Antigona: The Paperwhite does not appear to be using MTP, under 5.3.1 or 5.3.3 firmware. Also supports Calibre. –  david6 Jan 24 '13 at 10:03

2 Answers 2

I've stumbled upon the same problem. After installing mtpfs all worked fine.

sudo apt-get install mtpfs

Don't forget to remove and insert the usb cable again.

FYI: Mine is a Kindle Touch.

share|improve this answer
    
From what I can tell, the Paperwhite does not use MTP. It uses USB Mass Storage. Simply plugging the device in should work. I see no options for what protocol to use, either, on my Paperwhite. –  dobey Apr 25 '13 at 17:56
    
This answer is a solution if you have a "normal" Kindle. I have Kindle 5 and it worked for me. –  LucianU Dec 10 '13 at 18:32

You should just be able to install calibre sudo apt-get install calibre, and manage your Kindle Paperwhite. I don't have a new-ish kindle to test with, but that method has worked with the older kindles, and I don't think they changed it much.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.